Требует ли Unity проприетарных драйверов видеокарты?

Я понял, что рабочий стол Unity в Natty использует Compiz и поэтому требует драйвера видеокарты, поддерживающего композиционные эффекты. Означает ли это, что если у меня есть карта ATI или NVIDIA, я вынужден установить проприетарный драйвер, потому что драйверы с открытым исходным кодом для этих карт не поддерживают Compiz?

22 голоса | спросил Ralf Hersel 14 Jam1000000amFri, 14 Jan 2011 00:54:45 +030011 2011, 00:54:45

8 ответов


15

Я считаю, что Unity требует 3D-графики. Поэтому, если есть открытый драйвер, который может это сделать, вам не нужны проприетарные драйверы.

Глядя на статус драйверов FLOSS nouveau, в настоящее время вам, вероятно, понадобятся проприетарные драйверы для NVIDIA, однако, они работают над необходимыми функциями.

ответил txwikinger 14 Jam1000000amFri, 14 Jan 2011 01:04:55 +030011 2011, 01:04:55
11

Для людей, которые используют устаревшее оборудование или имеют проблемы с драйверами, Unity 2D interface будет доступен в 11.04 (и в PPA за 10.10)

ответил Jorge Castro 14 Jam1000000amFri, 14 Jan 2011 03:53:06 +030011 2011, 03:53:06
4

У меня есть карта ATI, и Unity /Compiz отлично работает для меня с открытыми драйверами в natty, хотя я уверен, что это зависит от состояния драйверов для вашей конкретной карты. Если ваша карта поддерживает компиляцию с открытыми драйверами, она также должна поддерживать единство.

Существует (впечатляюще длинный) список карт ATI с 3D-ускорением с открытым исходным кодом на https: //help.ubuntu.com/community/RadeonDriver

ответил cscarney 18 Jam1000000amTue, 18 Jan 2011 01:23:57 +030011 2011, 01:23:57
3

В Maverick я могу использовать Nouveau для своей графической карты Nvidia, и у меня есть 3D-графика; поэтому я считаю, что на Natty вы можете использовать драйверы с открытым исходным кодом, если хотите ..

ответил Martín Casco 14 Jam1000000amFri, 14 Jan 2011 02:23:02 +030011 2011, 02:23:02
3

Требование Unity заключается в том, что графический драйвер должен иметь поддержку 3D.

Для карт Nvidia потребуется проприетарный драйвер, поскольку драйвер с открытым исходным кодом не поддерживает 3D.

У меня есть ноутбук с набором микросхем Intel 945GM, у которого есть открытые драйверы для графики. Он также поддерживает 3D.

Ответ: Unity нуждается в поддержке 3D. Если на вашей карте есть драйвер FOSS, поддерживающий 3D, то вы в порядке, в противном случае вам нужно установить проприетарные драйверы.

ответил Manish Sinha 14 Jam1000000amFri, 14 Jan 2011 02:23:06 +030011 2011, 02:23:06
3

В настоящее время я запускаю Natty с Unity 3D на карте Nvidia, используя предоставленные экспериментальные драйверы 3D FOSS. Никаких проблем, кроме моих поклонников карт, ускоряется.

Если качество драйвера, по крайней мере, останется прежним, вам не понадобятся правильные карты Nvidia.

Драйвер nvidia-current пока не поддерживает новый Xorg.

ответил Seth Hikari 23 FebruaryEurope/MoscowbWed, 23 Feb 2011 04:13:11 +0300000000amWed, 23 Feb 2011 04:13:11 +030011 2011, 04:13:11
0

Короче: Нет.

Я слышал, что в Unity должен быть вариант с малой мощностью (2D).

ответил brews 18 Jam1000000amTue, 18 Jan 2011 00:54:03 +030011 2011, 00:54:03
0

Ответ: No: Compiz будет счастлив, пока ваш драйвер free /libre /open source имеет даже экспериментальную поддержку 3D-ускорения. У моего отца есть коробка AMD K7 с GeForce2 MX 400 (nv11). Я только что провел на нем насыщенную живую сессию, и Compiz хорошо показал мне все эффекты рабочего стола (кнопка «try Ubuntu» выбрала для меня резервный рабочий стол Gnome, хотя ...)

ответил Jesse Zixi Zhang 12 PM00000030000002531 2011, 15:10:25

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132