Выход HDMI работает с NOOBS, но не после установки ОС

Я новичок в RasPi. Я установил NOOBS на SD-карту. (отформатированный с использованием SDFormatter) При загрузке экран NOOBS появился на HDMI. Я выбрал Raspbian. После того, как NOOBS установил Raspbian и (я полагаю) загрузил ОС, не было HDMI. Теперь, когда я загружаюсь, я получаю HDMI до тех пор, пока он не пройдет мимо экрана, в котором мне будет предложено нажать Shift для настройки. Если я отпущу его, чтобы загрузить ОС, HDMI исчезнет. Если я удерживаю shift, тогда HDMI остается активным, и я получаю экран NOOBS.

Я проработал предложения по часто задаваемым вопросам на http://www.raspberrypi.org/faqs Любые другие предложения с благодарностью принимаются.

3 голоса | спросил TimxDunn 20 +04002013-10-20T05:38:54+04:00312013bEurope/MoscowSun, 20 Oct 2013 05:38:54 +0400 2013, 05:38:54

1 ответ


2

Я думаю, что это та же проблема, проверьте linquize решение: Пустой экран после установки Raspbian

Короче говоря, проблема в том, что файл конфигурации перезаписывается шаблоном. Вы можете попытаться завершить процесс загрузки и без сигнала на HDMI попытаться подключиться к Pi через SSH. Затем отредактируйте файл /boot/config.txt и раскомментируйте их, чтобы:

hdmi_drive=1
hdmi_force_hotplug=1

Другим решением является установка Raspbian непосредственно на SD-карте без использования NOOBS. После того, как он установлен на SD, установите SD-карту в Linux-box и отредактируйте файл /boot/config.txt, как указано выше, прежде чем загружать его на Pi.

ответил Sitron_NO 21 +04002013-10-21T07:28:10+04:00312013bEurope/MoscowMon, 21 Oct 2013 07:28:10 +0400 2013, 07:28:10

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132