Установите postgresql с игрой! framework (Драйвер не найден: [org.postgresql.Driver])

Я новичок в спектакле! рамки и postgresql, и я пытаюсь заставить его работать.

Я прочитал много вопросов, задаваемых по stackoverflow, и много искал в Google, но мне не удалось заставить его работать.

Вот ошибка, что Play! дает мне:

Driver not found: [org.postgresql.Driver] 

Мои вопросы:

1) Знаете ли вы простой учебник (то есть, который объясняет с самого начала), который показывает, как настроить игру! заставить postgresql работать? Я много чего читал, но не нашел подробного урока.

2) Если нет, вот моя конфигурация:

Я добавил это в application.conf:

db.default.driver=org.postgresql.Driver
db.default.url="jdbc:postgresql://127.0.0.1/postgres"
db.default.user=postgres
db.default.password=root

И в built.sbt:

libraryDependencies ++= Seq(
  jdbc,
  anorm,
  cache,
)  

Что я делаю не так?

12 голосов | спросил Simon 9 J0000006Europe/Moscow 2014, 20:39:44

1 ответ


0

Как сказано в документации, вы должны добавить драйвер в ваши зависимости:

libraryDependencies += "postgresql" % "postgresql" % "9.1-901-1.jdbc4"

Используйте соответствующую версию драйвера для вашей установки Postgres.

http://www.playframework.com/documentation/2.3.x/ScalaDatabase

ответил Ryan 9 J0000006Europe/Moscow 2014, 22:47:45

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132