android — Android Studio: сбой Gradle Sync с support-v4-24.1.1.jar" />

Android Studio: сбой Gradle Sync с support-v4-24.1.1.jar

У меня проблема с Gradle.     здесь ниже проблема в сообщении Gradle, делая синхронизацию в Gradle Наш Android Studio version is 2.1.2.

  

Ошибка: возникла проблема при настройке проекта ': LetMeCall_Store'.        Не удалось найти support-v4.jar (com.android.support:support-v4:24.1.1).         Поиск в следующих местах:              https://jcenter.bintray.com/ком /Android /поддержка /поддержка-v4 /24.1.1 /поддержка-v4-24.1.1.jar

Ниже приведен файл Gradle

apply plugin: 'com.android.application'

android {
    compileSdkVersion 24
    buildToolsVersion "24.0.1"

    defaultConfig {
        applicationId "com.app.letmecall.store"
        minSdkVersion 15
        targetSdkVersion 24
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'

    compile 'com.android.support:appcompat-v7:24.1.1'
    compile 'com.android.support:design:24.0.0-beta1'
    compile 'com.android.support:support-v4:24.0.0-beta1'
    compile 'com.android.support:recyclerview-v7:24.1.1'
    compile 'com.android.support:cardview-v7:24.0.0-beta1'
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile 'org.jbundle.util.osgi.wrapped:org.jbundle.util.osgi.wrapped.org.apache.http.client:4.1.2'
    compile 'com.loopj.android:android-async-http:1.4.6'
    compile 'com.daimajia.androidanimations:library:[email protected]'
    compile "com.google.android.gms:play-services:8.3.0"
    compile 'com.mcxiaoke.volley:library-aar:1.0.0'
    compile 'com.android.support:multidex:1.0.0'
}

Пожалуйста, помогите нам решить эту проблему. Заранее спасибо

7 голосов | спросил Naresh Koppera 30 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowFri, 30 Sep 2016 08:25:21 +0300 2016, 08:25:21

5 ответов


0

Я обновил все свои инструменты для Android SDK (включая «Репозиторий поддержки»), но все равно получил ошибку

  

Сбой синхронизации Gradle: не удалось найти recyclerview-v7.jar (com.android.support:recyclerview-v7:24.1.1)

Затем я сделал следующее:

  1. targetSdk 24 (было 23)
  2. buildToolsVersion: "24.0.3" (было 24.0.0)
  3. удалил папки в /.gradle/caches У меня есть окна, и полный путь - C: \ Users \ USERNAME \ .gradle \ caches

ТО проект собран без ошибок !!

ответил Someone Somewhere 24 +03002016-10-24T20:35:41+03:00312016bEurope/MoscowMon, 24 Oct 2016 20:35:41 +0300 2016, 20:35:41
0

Изменить это

compile 'com.android.support:design:24.0.0-beta1'
compile 'com.android.support:support-v4:24.0.0-beta1'
compile 'com.android.support:recyclerview-v7:24.1.1'
compile 'com.android.support:cardview-v7:24.0.0-beta1'

к этому

 compile 'com.android.support:design:24.1.1'
    compile 'com.android.support:support-v4:24.1.1'
    compile 'com.android.support:recyclerview-v7:24.1.1'
    compile 'com.android.support:cardview-v7:24.1.1'

вы должны использовать ту же версию.

ответил Ironman 30 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowFri, 30 Sep 2016 08:41:45 +0300 2016, 08:41:45
0
Replace with these


android {
    compileSdkVersion 23
    buildToolsVersion "23.0.1"

    defaultConfig {
        applicationId "com.stackdemo"
        minSdkVersion 11
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.1.1'
    compile 'com.android.support:design:23.1.1'

    compile 'com.android.support:recyclerview-v7:23.1.1'
    compile 'com.android.support:cardview-v7:23.0.0'
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile 'org.jbundle.util.osgi.wrapped:org.jbundle.util.osgi.wrapped.org.apache.http.client:4.1.2'
    compile 'com.loopj.android:android-async-http:1.4.6'
    compile 'com.daimajia.androidanimations:library:[email protected]'
    compile "com.google.android.gms:play-services:8.3.0"
    compile 'com.mcxiaoke.volley:library-aar:1.0.0'
    compile 'com.android.support:multidex:1.0.0'


}
ответил Krunal Pujara 30 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowFri, 30 Sep 2016 08:34:44 +0300 2016, 08:34:44
0

У меня та же проблема, и как только я обновляю версию инструмента сборки и Android Studio. Проблема решена. Вызывающе это связано с более старой версией инструмента сборки.

ответил Gopal Sharma 4 +03002016-10-04T12:12:18+03:00312016bEurope/MoscowTue, 04 Oct 2016 12:12:18 +0300 2016, 12:12:18
0

У меня возникла эта проблема с примером проекта от разработчиков Android. Я обновил все библиотеки в файле gradle до последних версий, а затем очистил & перестроил проект. Теперь все работает нормально.

Вероятно, это хорошая идея, чтобы убедиться, что все ваши SDK обновлены

ответил MichaelStoddart 10 +03002016-10-10T18:17:37+03:00312016bEurope/MoscowMon, 10 Oct 2016 18:17:37 +0300 2016, 18:17:37

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132