Какую версию hadoop использовать?

Оба hadoop в действии & окончательное руководство, оба построили свою основу из картографических классов. И большинство из этих классов устарели в 0.20.2. Подписи новых классов разные. Может кто-нибудь рассказать мне о различных сделанных изменениях. Например. класс разделителя устарел. Как новый редуктор собирается предоставить свою функцию. Изменения концепции, произошедшие в 0.20.2

Что я должен использовать? В Вадимке я вижу Скачать 1.0.X - текущая стабильная версия, выпуск 1.0 1.1.X - текущая бета-версия, выпуск 1.1 2.X.X - текущая альфа-версия 0.23.X - аналогично 2.X.X, но отсутствует NN HA. 0.22.X - не включает безопасность 0.20.203.X - старая стабильная версия 0.20.X - устаревшая версия

Означает ли это, что отображаемые классы устарели & были вновь введены. Какую версию hadoop я должен использовать? 0.20.2 или 1.0.x?

7 голосов | спросил S Kr 30 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowSun, 30 Sep 2012 01:47:35 +0400 2012, 01:47:35

1 ответ


0
  

Пожалуйста, проверьте это, это объясняет управление версиями разработки Hadoop:" rel =" noreferrer "> http://www.cloudera.com/blog/2012/04/apache-hadoop-versions-looking-ahead-3/

     

Таким образом, вы можете понять, почему у него достаточно сложные версии.

     

p /s: я использую v1.0.3 для моей системы:)

Это пост в апреле. :)

Но любой может согласиться с тем, что версии в лучшем случае вводят в заблуждение.

ответил Admin 16 +04002012-10-16T22:44:11+04:00312012bEurope/MoscowTue, 16 Oct 2012 22:44:11 +0400 2012, 22:44:11

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132