Как определить, совместим ли браузер с ES2015 [дубликат]

    

На этот вопрос уже есть ответ здесь:

    

У меня есть большой кусок библиотек JS, которые я должен переписать, так как он действительно старый и устаревший. Поэтому я решил найти решение, в котором я бы использовал большинство функций ES2015 , например остальные параметры .

Дело в том, что я уверен, что все клиенты не будут обновлять свой браузер, и я не понимаю, столкнусь ли я с какой-либо проблемой, связанной с совместимостью их браузера с моими новыми библиотеками JS.

Итак, мне было интересно, смогу ли я определить, совместимы ли клиентские браузеры с ES2015. А если нет, я бы просто включил мою старую библиотеку JS.

Я ищу решение, например Условные комментарии , но я не могу найти решение.

Любая помощь в HTML, JS или PHP приветствуется. Пожалуйста, предложите ваш совет.

7 голосов | спросил choz 4 Jpm1000000pmMon, 04 Jan 2016 19:47:39 +030016 2016, 19:47:39

0 ответов


Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132