«Невозможно запустить отладку на веб-сервере» MSVSMON.EXE не удалось запустить.Ошибка VS2010

возникла реальная проблема с получением VS2010 для отладки IIS.Я искал в Интернете в течение нескольких дней и попробовал каждое возможное решение.VS2008 работает отлично, но я установил VS2010 и при попытке отладки сайта IIS (нажав F5 в проекте, который использует IIS), я получаю сообщение об ошибке«Не удалось запустить отладку на веб-сервере. Не удалось запустить Microsoft Visual Studio Debugging Monitor (MSVSMON.EXE). Если эта проблема не устранена, восстановите установку Visual с помощью« Установка и удаление программ »на панели управления.»когда я пытаюсь присоединить процесс вручную, я получаю то же сообщение.Я пытался восстановить программное обеспечение.Я попробовал это, это не удалось, поэтому я удалил с помощью утилиты удаления Microsoft Visual Studio 2010 (http://archive.msdn.microsoft.com/vs2010uninstall/Release/ProjectReleases.aspx?ReleaseId=4321), затем переустановил, и он по-прежнему имеетта же проблема.С обновлением SP1 это все еще происходит.Я могу нормально запустить веб-сайт, когда запускается «запуск без отладки», и он работает нормально.Я просмотрел все руководства, которые смог, и все перепробовал все настройки на IIS, которые я могу, и до сих пор не повезло.Я использую Windows 7 64bit, если это что-то значит.Я могу подробнее рассказать обо всем, что я пробовал.также есть ноутбук и сделали то же самое, установив VS2010 и TFS (также на win7 64bit), и это отлично работает для отладки.Не пришлось возиться вообще.Я не вижу никакой разницы между этим и моим ПК с проблемой.Я чешу голову здесь и думаю, что мне, возможно, придется отформатировать мой компьютер и попробовать еще раз с новой установки (что будет серьезно раздражать!)Спасибо всем, кто читает это, Дэн Гент
4 голоса | спросил Buswell 29 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowThu, 29 Sep 2011 15:31:16 +0400 2011, 15:31:16

8 ответов


0
я исправил это сейчас.в итоге отформатировал машину, переустановил windows 7, а потом делал резервные копии каждый раз, когда я устанавливал новую программу, чтобы я мог откатиться.сначала установил VS2010, работал F5.затем установил VS2008 и все остальное и отладка все еще работает на VS2010.не уверен, что случилось, поскольку вышеупомянутая проблема произошла на новой установке.что-то должно быть что-то испортилоспасибо за вашу помощь и сужение этой проблемы до того, что стоило отформатировать мой компьютер, чтобы исправить.ура, Бусвелл
ответил Buswell 5 +04002011-10-05T20:03:35+04:00312011bEurope/MoscowWed, 05 Oct 2011 20:03:35 +0400 2011, 20:03:35
0
У меня была запись в файле HOSTS, разрешающая URL проекта на сервер DEV вместо локальной машины.Изменение записи на 127.0.0.1 решило проблему.
ответил user2299804 19 PMpFri, 19 Apr 2013 19:20:14 +040020Friday 2013, 19:20:14
0
Вы устанавливаете с купленного диска или загрузили?В любом случае, вам нужно скачать новую копию и установить ее (звучит как оригинал поврежден).Также убедитесь, что на вашем компьютере установлены все компоненты IIS и Web.Ваша ОС дома или базовая?http://technet.microsoft.com/en-us/library/cc731911.aspx
ответил IrishChieftain 29 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowThu, 29 Sep 2011 18:23:55 +0400 2011, 18:23:55
0
Это также может быть вызвано тем, что вы используете имя хоста в IIS и допустили ошибку в файле хостов.Убедитесь, что IP-адрес хоста установлен на локальном компьютере 127.0.0.1, а не где-либо еще.В моем случае я случайно установил его на сервер разработки.
ответил 79E09796 3 J000000Tuesday12 2012, 14:14:49
0
Вы пытались запустить MSVSMON вручную?У меня была такая же проблема, как вы, и обнаружил, что служба была остановлена.Поэтому я попытался включить службу и убедился, что она использует правильные учетные данные.Надеюсь, это поможет!Спасибо!дон
ответил dmarges 21 J0000006Europe/Moscow 2012, 00:13:04
0
Единственное, что сработало для меня после того, как я попробовал практически все решения в Интернете, - это щелкнуть правой кнопкой мыши проект в обозревателе решений и выбрать «Отладка-> Отладка в качестве администратора».
ответил ury 23 SunEurope/Moscow2012-12-23T19:14:57+04:00Europe/Moscow12bEurope/MoscowSun, 23 Dec 2012 19:14:57 +0400 2012, 19:14:57
0
Щелкните правой кнопкой мыши Project, флажок «Использовать пользовательский веб-сервер» будет установлен, установите флажок «Использовать локальный веб-сервер IIS».Я решил эту проблему с этим и его работой.
ответил Altaf Sami 22 Mayam13 2013, 09:21:50
0
Эту ошибку удалось устранить с помощью обозревателя решений-> щелкните правой кнопкой мыши проект-> выберите Отладка-> Начать новый экземпляр.Я думаю, что это потому, что я скопировал папку проекта с другого сервера.
ответил Ling 17 +03002016-10-17T06:45:48+03:00312016bEurope/MoscowMon, 17 Oct 2016 06:45:48 +0300 2016, 06:45:48

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132