ошибка: поле 'ctx' имеет неполный тип EVP_CIPHER_CTX

Проблема: мне нужно установить Cepstral (tts engine) в Freeswitch под управлением Debian 8. Freeswitch уже запущен и работает, но мне нужно было собрать его из исходного кода, чтобы он создал модуль mod_cepstral.Когда я запускаю ---- +: = 0 =: + ---- я получаю ошибку:Я искал в интернете решения, но я не разработчик, и это слишком сложно.Любая помощь будет оценена.
4 голоса | спросил Joe 27 12017vEurope/Moscow11bEurope/MoscowMon, 27 Nov 2017 22:56:30 +0300 2017, 22:56:30

3 ответа


0
Поговорив с поддержкой в ​​Cepstral, мы определили, что Джесси (Debian 8) еще не полностью совместим.Я перестроил сервер с Debian 7, и теперь он работает нормально.
ответил Joe 28 ThuEurope/Moscow2017-12-28T23:56:10+03:00Europe/Moscow12bEurope/MoscowThu, 28 Dec 2017 23:56:10 +0300 2017, 23:56:10
0
Получить последнюю версию ---- +: = 1 =: + ---- .
ответил mikeb 28 ThuEurope/Moscow2017-12-28T22:06:09+03:00Europe/Moscow12bEurope/MoscowThu, 28 Dec 2017 22:06:09 +0300 2017, 22:06:09
0
Похоже, что есть зависимость от OpenSSL, но используемая вами версия OpenSSL несовместима.Вы используете OpenSSL 1.1.0, но вам нужно использовать OpenSSL 1.0.2
ответил Matt Caswell 28 22017vEurope/Moscow11bEurope/MoscowTue, 28 Nov 2017 02:32:42 +0300 2017, 02:32:42

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132