Выходной размер уценки R

Я хочу создать страницу уценки R с помощью интерактивного блестящего приложения. Это работает нормально, но вывод находится в очень маленькой области с полосами прокрутки. Я хочу избавиться от полос прокрутки и показать 2 фигуры с полной шириной и высотой без полос прокрутки. Как мне этого добиться?

Я уже пробовал:

options(width = 800)

В настоящее время это выглядит так:

    ---
title: "Spielercluster"
output: html_document
runtime: shiny
---
```{r,echo=FALSE}
library(ggplot2)
library(shiny)

data<-read.csv2('data.csv',header=T,sep=",") 
rawData<-read.csv2('rawData.csv',header=T,sep=",")
cluster<-read.csv2('cluster.csv',header=T,sep=",")
colors<-c("green","red","black")

ui<-fluidPage(plotOutput("plot1", hover = "plot_hover"),
              plotOutput("plot2", hover = "plot_hover"),
              verbatimTextOutput("info")
)

server <- function(input, output) {

  output$plot1 <- renderPlot({
ggplot(rawData, aes(koerpergewicht, groesse, color =  factor(data$gruppe))) +
          geom_point() + labs(title = paste(nlevels(factor(colors))))+geom_point(size=8)+geom_text(aes(label=position),vjust=-1.5)+scale_color_manual(name = "Gruppe",
  labels = c("1 schwer", "2 leicht","3 Zwischengruppe"),
  values = c(rgb(0.9725490196078431,0.4627450980392157,0.4274509803921569,1),rgb(0,0.7294117647058824,0.2196078431372549,1),rgb(0.3803921568627451,0.6117647058823529,1,1)))+ggtitle("Original")
  })

  output$plot2 <- renderPlot({
ggplot(rawData, aes(koerpergewicht, groesse, color =  factor(cluster$x))) +
          geom_point() + labs(title = paste(nlevels(factor(colors))))+geom_point(size=8)+geom_text(aes(label=position),vjust=-1.5)+scale_color_manual(name = "Gruppe",
  labels = c("1 schwer", "2 leicht","3 Zwischengruppe"),
  values = c(rgb(0.9725490196078431,0.4627450980392157,0.4274509803921569,1),rgb(0,0.7294117647058824,0.2196078431372549,1),rgb(0.3803921568627451,0.6117647058823529,1,1)))+ggtitle("Berechnet")
  })


  output$info <- renderPrint({
    nearPoints(rawData, input$plot_hover, , threshold = 10, maxpoints = 1,
               addDist = TRUE)
  })
}

shinyApp(ui, server)
```
4 голоса | спросил Kewitschka 5 AMpTue, 05 Apr 2016 11:40:01 +030040Tuesday 2016, 11:40:01

5 ответов


0

Я достиг этого, добавив свой собственный файл CSS. Вы можете включить его так:

---
title: "Spielercluster"
output:
  html_document:
    css: style.css
runtime: shiny
---

Затем вам нужно настроить размеры класса блестящая рамка

.shiny-frame{
  width: 1400px;
  height: 1200px;
}
ответил Kewitschka 5 PMpTue, 05 Apr 2016 12:21:42 +030021Tuesday 2016, 12:21:42
0

shinyApp(ui, server, options = list(height = 1000)

  

Обратите внимание на использование параметра высоты, чтобы определить, сколько вертикального пространства   встроенное приложение должно занимать. http://rmarkdown.rstudio.com/authoring_embedded_shiny.html )

ответил mluerig 8 FebruaryEurope/MoscowbThu, 08 Feb 2018 01:36:16 +0300000000amThu, 08 Feb 2018 01:36:16 +030018 2018, 01:36:16
0

Когда вы превращаете блестящий файл в Markdown, я думаю, вам следует удалить сервер и функцию пользовательского интерфейса, потому что это не обычный файл rmarkdown, тогда он покажет всю блестящую графику. Я решил эту проблему, действуя таким образом. Вы можете изменить блестящий в этот формат.

Вот ссылка: изменить блестящий формат на rmarkdown

ответил Fangfei Gao 2 FriEurope/Moscow2016-12-02T01:10:46+03:00Europe/Moscow12bEurope/MoscowFri, 02 Dec 2016 01:10:46 +0300 2016, 01:10:46
0

Я нахожусь на R Shiny Server Pro 1.5.11.994 и CentOs 7.5.

После работы с сервером options, размеры фигуры (например, fig.width, или fig.fullwidth), и размеры графиков, что в конечном итоге мне помогло - CSS.

Вот вершина моего файла уценки:

---
output:
  html_document:
    css: my_styles.css
---

, а затем в my_styles.css:

div.main-container {
  max-width: 100%;
  margin-left: auto;
  margin-right: auto;
}

.shiny-frame {
  height: 800px;
}
ответил Kode Charlie 9 AMpTue, 09 Apr 2019 02:05:04 +030005Tuesday 2019, 02:05:04
0

Для глобальной настройки

knitr::opts_chunk$set(fig.width = 12, fig.height=8)

или локально для каждого выхода

```{r,echo=FALSE, fig.width = 12, fig.height=8}

должно работать.

ответил iboboboru 5 AMpTue, 05 Apr 2016 11:47:41 +030047Tuesday 2016, 11:47:41

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132