Как отслеживать трафик Vlan?

Мы перешли на нового интернет-провайдера, который предоставил нам несколько услуг (Internet + VoIP + VoD) и разделил каждую услугу на один vlan 100,101,102 соответственно. Теперь я ищу решение для мониторинга каждой службы и измерения пропускной способности на каждом vlan. Я знаю, что у нас нет счетчиков интерфейса L3 SVI. Я, хотя суб-интерфейс портового канала имеет счетчики, но не работает.

Мы получаем на 4500-X 3 vlans /services и передаем их на vlan 604 в CMTS. VLAN 260 предназначен для многоадресной передачи IPTV.

В общем, я использую cacti для мониторинга пропускной способности на интерфейсе, и мне нужен аналогичный способ сделать это на vlans.

Возможно, Netflow может решить проблему, но прежде чем инвестировать в нее, я бы хотел, чтобы ваши соображения нашли более простое решение как Cacti.

Здесь топология

 ============4500-X==================
!----------ingress - From ISP-----------------
sw-4500-X#sh run int te1/1/15 
Building configuration...

Current configuration : 171 bytes
!
interface TenGigabitEthernet1/1/15
 description Po from ISP 
 switchport trunk allowed vlan 100-102
 switchport mode trunk
 channel-group 5 mode active
end

sw-4500-X#sh run int te2/1/15
Building configuration...

Current configuration : 171 bytes
!
interface TenGigabitEthernet2/1/15
 description Po from ISP 
 switchport trunk allowed vlan 100-102
 switchport mode trunk
 channel-group 5 mode active
end

!----------egress port to CMTS------------------
sw-4500-X#sh run int te1/1/1
Building configuration...

Current configuration : 192 bytes
!
interface TenGigabitEthernet1/1/1
 description link Po1 -> CMTS (te2/0/0)
 switchport trunk allowed vlan 260,706
 switchport mode trunk
 load-interval 30
 channel-group 1 mode on
end

sw-4500-X#sh run int te2/1/1
Building configuration...

Current configuration : 192 bytes
!
interface TenGigabitEthernet2/1/1
 description link Po1 -> CMTS (te1/0/0)
 switchport trunk allowed vlan 260,706
 switchport mode trunk
 load-interval 30
 channel-group 1 mode on
end
 

ИЗМЕНИТЬ:

Здесь вывод snmpwalk

 [[email protected] ~]# snmpwalk -v 2c -c rw_community <IP-4500-x> IF-MIB::ifName
....
IF-MIB::ifName.168 = STRING: VLAN-100  
IF-MIB::ifName.169 = STRING: VLAN-101   
IF-MIB::ifName.170 = STRING: Vl100  
IF-MIB::ifName.171 = STRING: VLAN-102  
IF-MIB::ifName.172 = STRING: Vl101  
IF-MIB::ifName.173 = STRING: Vl102  
...

[[email protected] ~]# snmpwalk -v 2c -c rw_community <IP-4500-x> IF-MIB::ifName.168
IF-MIB::    IFName.168 = STRING: VLAN-100
[[email protected] ~]# snmpwalk -v 2c -c rw_community <IP-4500-x>     IF-MIB::    IFHCInUcastPkts.168
IF-MIB::    IFHCInUcastPkts.168 = No Such Instance currently exists at this OID
[[email protected] ~]# snmpwalk -v 2c -c rw_community <IP-4500-x>     IF-MIB::    IFHCOutUcastPkts.168
IF-MIB::    IFHCOutUcastPkts.168 = No Such Instance currently exists at this OID
[[email protected] ~]# snmpwalk -v 2c -c rw_community <IP-4500-x>     IF-MIB::    IFHCInOctets.168
IF-MIB::    IFHCInOctets.168 = No Such Instance currently exists at this OID
[[email protected] ~]# snmpwalk -v 2c -c rw_community <IP-4500-x>     IF-MIB::    IFHCOutOctets.168
IF-MIB::    IFHCOutOctets.168 = No Such Instance currently exists at this OID
 

Но если я попробую с .170, я получаю

 [[email protected] ~]# snmpwalk -v 2c -c rw_community <IP-4500-x> IF-MIB:ifHCInUcastPkts.170
IF-MIB::ifHCInUcastPkts.170 = Counter64: 0
[[email protected] ~]# snmpwalk -v 2c -c rw_community <IP-4500-x> IF-MIB:ifHCOutOctets.170
IF-MIB::ifHCOutOctets.170 = Counter64: 325414481
 

Возникает еще один вопрос: Почему это различие в одном интерфейсе (VLAN-100 и Vl100)?

Мой главный вопрос по-прежнему остается без ответа, потому что OID, который я получаю, предназначен для интерфейсов пакетов и байтов.

То, что я хочу получить, это измерение пропускной способности на некоторых vlan. До сих пор я рассматриваю Netflow как вероятное решение.

EDIT2:

Я пытаюсь добавить кактусы, и у меня проблема.

График показал, когда я добавляю интерфейс vlan100:

cacti

Как добавить такой интерфейс и сделать расчет, чтобы показать правильный график трафика? как было предложено Майком Пеннингтоном

14 голосов | спросил cgasp 28 J0000006Europe/Moscow 2013, 14:13:30

3 ответа


10

Попробуйте добавить команду counter в SVI (см. here для получения дополнительной информации, в частности раздела «Понимание интерфейса L3»).

Например:

  Cisco#config t
 Cisco(config)#interface vlan 100
 Cisco(config-if)#counter ?
   ipv4  Enable IPv4 statistic counters
   ipv6  Enable IPv6 statistic counters
   <cr>
 Cisco(config-if)#counter
 Cisco(config-if)#end
 

В сочетании с превосходными ответами Майка это, вероятно, будет тем, что вы хотите.

ответил YLearn 13 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowFri, 13 Sep 2013 03:23:52 +0400 2013, 03:23:52
16

Опрос ifHCInUcastPkts , ifHCOutUcastPkts , ifHCInOctets и ifHCOutOctets на Vlan100, Vlan101 и Vlan102. Вы можете найти ifIndex этих SVI, пройдя ifName

  

Возникает еще один вопрос: почему это различие в одном интерфейсе (VLAN-100 и Vl100)?

  • VLAN-100 - это виртуальный интерфейс для реального слоя vlan; нет связанного с ним IP-адреса, и поэтому он не может иметь счетчики, которые вы пытаетесь опросить.
  • Vlan100 - это SVI, поэтому вы можете получить IP-счетчики для него.
  

Мой главный вопрос по-прежнему остается без ответа, потому что OID, который я получаю, предназначен для счетчиков пакетов и байтов на интерфейсе.

Это все, что SNMP даст вам в отношении пропускной способности; каждая станция мониторинга SNMP на планете (например, кактусы , Observium или Graphite ) выводит графики пропускной способности интерфейса из этих же байтовых счетчиков (т.е. ifHCInOctets /ifHCOutOctets ).

  

То, что я хочу получить, это измерение пропускной способности на некоторых vlan. До сих пор я рассматриваю Netflow как вероятное решение.

Вы можете использовать любой инструмент, который вам нравится. Однако я не уверен, как просто переключение на Netflow помогает ... Системы NMS (независимо от того, говорят ли они по протоколу SNMP или Netflow), являются сложными животными ...

ответил Mike Pennington 28 J0000006Europe/Moscow 2013, 14:26:26
0

Ответ Майка очень важен, и я бы пошел с ним, если это более подходит для вас.

Я основываю этот ответ на двух пунктах вашего вопроса 1) У вас нет способа отслеживать трафик vlan, и вы хотите контролировать их (три vlans - 100, 101 и 102) 2) У вас есть способ отслеживания трафика интерфейса.

Я хотел бы предложить использовать функцию SPAN (Switched Port Analyzer) для этого. http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/12-2/25ew/configuration/guide/conf/span.html#wp1044290 Вот как это происходит.

Сценарий 1 Вы сохраняете свой пункт назначения порта в другом коммутаторе, и вы хотите собирать трафик с разных коммутаторов.

1) Сделайте три новых vlans - 200, 201 и 202. Это будет использоваться исключительно для целей SPAN.

2) В каком бы коммутаторе вы хотели бы собирать трафик, настройте источник SPAN как трафик vlan (100 или 101 или 102) и настройте назначение SPAN как соответствующий парный vlan (200, 201 или 202)

3) Вам необходимо создать эти vlans 200, 201 и 202 во всех коммутаторах от переключателя источника до коммутатора назначения, где ваш мониторинг должен быть выполнен

4) В коммутаторе назначения выделите три порта и настройте их в соответствующих vlans 200, 201, 202.

5) Настройте RSPAN с источником как vlans (200, 201 и 202) и настройте конечный пункт как соответствующие интерфейсы, которые вы только что настроили.

6) Контролируйте эти интерфейсы так же, как вы будете контролировать любой другой интерфейс с помощью вашего инструмента.

Сценарий 2 Вы хотите отслеживать трафик, проходящий через только один коммутатор (в частности, ваш коммутатор 4500) В этом случае это намного проще. Это решение относится к 4500. http://www.cisco.com/c/en/us/support/docs/switches/catalyst-6500-series-switches/10570-41.html#anc30

Вышеупомянутая ссылка сообщает вам, как вы можете контролировать определенные vlans на соединительной линии в 4500.

Надеюсь, это было полезно.

ответил srikanth chandrasekaran 31 J000000Monday17 2017, 01:07:58

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132