Как отключить Bluetooth при запуске системы?

Как отключить Bluetooth при запуске системы?

270 голосов | спросил Floqqi 17 +04002011-10-17T01:02:42+04:00312011bEurope/MoscowMon, 17 Oct 2011 01:02:42 +0400 2011, 01:02:42

28 ответов


187

18.04+ пользователи, которые, естественно, не имеют /etc/rc.local, вам нужно создать его и сделать его исполняемым. Чтобы сделать что-то немного проще, вы можете просто вставить следующую команду в терминал:

  sudo install -b -m 755 /dev /stdin /etc/rc.local <<<EOF
#! /Bin /ш
Блокировка bluetooth
выход 0
EOF
 

Запустите sudoedit /etc/rc.local и добавьте это перед строкой с exit 0 :

  rfkill bluetooth
 

Вы все равно сможете включить Bluetooth через апплет верхнего бара.

Этот должен работать для большинства систем, но похоже, что в ядре ACPI для Thinkpads имеется несколько ошибок. Если вы используете Thinkpad, добавьте следующее в /etc/rc.local :

  echo disable> /Труды /ACPI /IBM /Bluetooth
 

Или зайдите в ibm-acpi - драйвер IBM Extractor от IBM ThinkPad ACPI - некоторые отчеты показывают, что ibm-acpi включает в себя управление bluetooth (среди других приятных вещей). Но у меня нет оборудования, поэтому я полностью не могу проверить эти претензии. Удачи.

ответил Oli 18 PM00000010000003631 2010, 13:00:36
67

Я нашел практическое руководство с чистым «обходным решением» здесь ( ссылка на архив для потомков)

На самом деле для меня было достаточно изменить /etc/bluetooth/main.conf .

Из статьи:

Поиск записи:

  InitiallyPowered = true
 

и измените значение на:

  InitiallyPowered = false
 

Этого было достаточно для меня, хотя в статье описаны некоторые другие шаги, которые могут или не могут быть необходимы.

В Ubuntu 17.10 и Ubuntu 18.04 опция InitiallyPowered была заменена на AutoEnable

ответил Stepbaer 25 J0000006Europe/Moscow 2012, 22:00:40
23

Чтобы отключить драйвер bluetooth при загрузке при запуске:

  sudo $ EDITOR /etc/modprobe.d/blacklist.conf
 

добавить:

  черный список btusb
 

Включение этого позже должно быть только:

  sudo modprobe btusb
 
ответил maco 18 PM00000080000000331 2010, 20:59:03
16

Шаг 1. Перейдите к терминалу и введите следующую команду, чтобы отредактировать файл /etc/rc.local :

  gksudo gedit /etc/rc.local
 

Шаг 2: добавьте следующую строку до строки exit 0 :

  rfkill bluetooth
 
ответил Varun 5 Mayam12 2012, 00:44:08
12

Начиная с ubuntu 16.04, система systemd управляет службами запуска, такими как bluetooth ... для просмотра текущей проблемы состояния, следующей в терминале

  sudo systemctl status bluetooth.service
 

для деактивации bluetooth при запуске этой проблемы

  sudo systemctl отключить bluetooth.service
 

, то при следующей перезагрузке bluetooth не будет активным ... для включения проблемы с Bluetooth.

  sudo systemctl включить bluetooth.service
 
ответил Scott Stensland 1 PM00000060000000031 2017, 18:08:00
7

Введите в терминал следующее:

  sudo gedit /etc/modprobe.d/blacklist.conf
 

В нижней части файла добавьте строку:

  черный список bluetooth
 

Сохраните файл и перезапустите - теперь Bluetooth должен быть отключен.

ответил Nathan Osman 17 +04002011-10-17T01:25:20+04:00312011bEurope/MoscowMon, 17 Oct 2011 01:25:20 +0400 2011, 01:25:20
7

Вы можете изменить службы, запущенные при загрузке, с помощью BUM .

Установите его: sudo apt-get install bum

Запуск: sudo bum

введите описание изображения здесь>> </p>

<p> Снимите флажок и нажмите <kbd> Применить </kbd>. </p></div>
					 
						<div class=

ответил desgua 5 Mayam12 2012, 04:09:08
5

Я думаю, что лучший способ - отключить сервис от запуска в первую очередь. Существует общий метод отключения служб, который отлично работает:

  sudo sh -c "echo 'manual'> /etc/init/bluetooth.override"
 

Это работает для Ubuntu 13.10 и, возможно, для более ранних версий.

ответил Felipe 18 Jpm1000000pmSat, 18 Jan 2014 13:49:18 +040014 2014, 13:49:18
5

Я добавляю

  "/etc /init.d /bluetooth stop"
 

в

  "/и т.д. /rc.local"
 

перед командой «exit 0» для загрузки с отключенным Bluetooth.

ответил Saeed Zarinfam 23 PM00000050000002931 2012, 17:00:29
5

1. блочный bluetooth в rc.local

Добавьте эту строку в конец файла /etc/rc.local прямо перед строкой exit 0 :

  rfkill bluetooth
 

Это сделает трюк, но только в более старых версиях Ubuntu, используя выскочку .

2. reenable rc.local на systemd

В Ubuntu 15.10 с systemd в качестве менеджера запуска файл /etc/rc.local больше не используется по умолчанию, поэтому вызовите это на терминале:

  sudo systemctl edit --full rc-local
 

Открывает редактор. В конце файла я добавил:

  [Установить]
WantedBy = multi-user.target
 

Эти изменения активируются

  sudo systemctl reenable rc-local
 

Теперь файл /etc/rc.local используется, как вы его знаете.

3. отключить blueman-апплет при запуске

  sudo sed -i 's /NoDisplay = true /NoDisplay = false /g' /etc/xdg/autostart/blueman.desktop
гном-сессия недвижимость
 

Теперь blueman-апплет виден, и вы можете отключить его от программ запуска

4. Перезагрузите, чтобы увидеть эффект

ответил rubo77 10 22015vEurope/Moscow11bEurope/MoscowTue, 10 Nov 2015 15:29:48 +0300 2015, 15:29:48
4

Вы можете изменить настройки update-rc.d . Я использовал что-то похожее на:

  sudo update-rc.d bluetooth удалить
 

В Debian Wheezy. Ознакомьтесь с man update-rc.d для получения дополнительной информации о том, как его использовать.

ответил Keith Smiley 13 FebruaryEurope/MoscowbWed, 13 Feb 2013 19:50:54 +0400000000pmWed, 13 Feb 2013 19:50:54 +040013 2013, 19:50:54
2

Возможно, вы можете отключить его в приложениях запуска. Но эти приложения скрыты по умолчанию. Покажите скрытые приложения для запуска в 12.04: откройте терминал и выполните следующие две команды:

  cd /etc /xdg /autostart /

sudo sed - in-place 's /NoDisplay = true /NoDisplay = false /g' * .desktop
 

Теперь вы можете снять отметку с bluetooth. (Не удаляйте!)

ответил schiemanski 5 Maypm12 2012, 12:50:40
2

Нет. Он не всегда находится в списке приложений для запуска. Я считаю, что лучшим решением является добавление команды rfkill в скрипт rc.local или установка параметра InitiallyPowered в /etc/bluetooth/main.conf .

ответил Robert 5 Mayam12 2012, 04:06:46
2

1) Установите пакет smbios-utils и добавьте его в Запуск приложений с помощью

  sudo smbios-wireless-ctl --bt 0
 

2) В типе терминала:

  sudo visudo
 

и добавьте в конец открытого файла /etc /sudoers строку:

  <ваше имя пользователя> ALL = NOPASSWD: /usr /sbin /smbios-wireless-ctl
 

3) Чтобы включить Bluetooth во время сеанса, запустите в терминале:

  sudo smbios-wireless-ctl --bt 1
 

Это работает для меня на моем Dell D630 с Ubuntu 13.10

ответил victor 15 MarpmSat, 15 Mar 2014 19:58:39 +04002014-03-15T19:58:39+04:0007 2014, 19:58:39
2

В Ubuntu 16.04 я просто отключил службу от запуска с помощью systemctl.

Для этого откройте окно терминала и введите следующее:

sudo systemctl disable bluetooth

Вы можете либо перезагрузиться, так как теперь bluetooth будет отключен от запуска, или если вы не хотите перезагружаться и хотите немедленно отключить Bluetooth, вы можете ввести:

sudo service bluetooth stop

ответил Ken 22 AM00000060000005431 2017, 06:57:54
2

Мы можем отключить автоматический запуск Bluetooth следующим образом:

sudo gedit /etc/bluetooth/main.conf

( gedit - мой редактор fav, вы можете заменить его на xed или что-то, что установлено в вашей системе.)

В самом низу этого файла есть следующая строка:

# AutoEnable = ложь

Отмените комментарий, например:

  AutoEnable = ложь
 
ответил Shayan 20 FebruaryEurope/MoscowbTue, 20 Feb 2018 17:47:41 +0300000000pmTue, 20 Feb 2018 17:47:41 +030018 2018, 17:47:41
1

Я использую Ядро Спутника , которое зафиксировало это на моем Dell Inspiron 14R N4110.

ответил Alex Wiedermann 25 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowTue, 25 Sep 2012 03:53:33 +0400 2012, 03:53:33
1

Думаю, вам следует отредактировать

  /и т.д. /по умолчанию /Bluetooth
 

и установите

  BLUETOOTH_ENABLED = 0
 

, чтобы отключить службу bluetooth при загрузке

ответил Fabio 7 MaramFri, 07 Mar 2014 00:17:01 +04002014-03-07T00:17:01+04:0012 2014, 00:17:01
1

Для тех из вас, где вставка строки rfkill block bluetooth (или любой другой) в /etc/rc.local не работает, попробуйте включить тот же строка в конце ~ /.bashrc

В моей настройке (Ubuntu 14.04, Thinkpad W540) никакая опция не работала, вставляя ее в /etc/rc.local , но первая работала в bashrc. Обратите внимание, что это будет работать только для текущего пользователя, а не для всех пользователей.

ответил Sam 19 +04002014-10-19T16:10:34+04:00312014bEurope/MoscowSun, 19 Oct 2014 16:10:34 +0400 2014, 16:10:34
1

В Ubuntu Studio 16.04 вы можете отключить апплет Bluetooth при запуске в:

  

Сессия и запуск> Приложение Autostart> Апплет Bluetooth

Здесь вы можете щелкнуть по полю, чтобы отключить его.

ответил ateymuri 26 PM00000090000004931 2016, 21:05:49
0

Я добавляю

"/etc /init.d /bluetooth stop"

в

  "/и т.д. /rc.local"
 

перед командой «exit 0» для загрузки с отключенным Bluetooth.

ответил Saeed Zarinfam 23 PM00000050000001831 2012, 17:05:18
0

Решение для моего ноутбука

"BIOS - Конфигурация USB - EHCI2: Отключено"

EHCI1 для портов usb (на самом деле у моего ноутбука есть 2 USB 2.0 порта)

ответил MSP 27 MarpmThu, 27 Mar 2014 22:46:35 +04002014-03-27T22:46:35+04:0010 2014, 22:46:35
0

Изменить /etc /default /grub :

  sudo nano /etc /default /grub
 

и измените следующую строку:

  GRUB_CMDLINE_LINUX = ""
 

, чтобы сказать это:

  GRUB_CMDLINE_LINUX = "bluetooth.blacklist = да"
 

Затем обновите grub и перезагрузитесь:

  sudo update-grub
 
ответил mchid 21 stEurope/Moscowp30Europe/Moscow09bEurope/MoscowMon, 21 Sep 2015 08:58:30 +0300 2015, 08:58:30
0

Это должно отключить запуск bluetooth в системах на базе Debian:

  sudo chkconfig bluetooth off
 

или на системах на основе RedHat

  systemctl отключить bluetooth.service
 
ответил Stanislav 16 +03002017-10-16T23:18:19+03:00312017bEurope/MoscowMon, 16 Oct 2017 23:18:19 +0300 2017, 23:18:19
0

Если вы используете апплет Bluetooth на верхней панели (blueman-апплет), у него есть свой собственный параметр, который автоматически включает Bluetooth, даже если вы отключили его в других местах (например, /etc /bluetooth /main .conf или /etc /default /tlp).

Чтобы предотвратить включение Bluetooth при запуске с помощью командной строки:

  gsettings set org.blueman.plugins.powermanager auto-power-on false
 

Или через GUI:

  1. Нажмите апплет Bluetooth> Плагины > PowerManager > Конфигурация
  2. Снимите флажок Автоматическое включение питания

В следующий раз, когда вы перезагрузитесь, апплет Bluetooth по-прежнему будет виден, но Bluetooth будет выключен. Чтобы включить его:

Нажмите апплет Bluetooth> Включить Bluetooth

ответил bmaupin 27 J000000Friday18 2018, 20:12:06
-1

Мне пришлось использовать метод грубой силы, чтобы остановить запуск bluetoothd при загрузке автоматически. Я переименовал исполняемый файл, чтобы его не удалось найти.

ответил bluesdiva2001 6 J000000Friday12 2012, 05:02:17
-1

Вы также можете использовать это графическое приложение, которое также выполняет менеджер bluetooth

ответил deFreitas 27 SatEurope/Moscow2014-12-27T16:26:12+03:00Europe/Moscow12bEurope/MoscowSat, 27 Dec 2014 16:26:12 +0300 2014, 16:26:12
-3

Вам нужно отключить его из списка «Запуск приложений» в «Системные настройки».

Нажмите на шестерню в верхней правой части панели меню, а затем выберите «Настройки системы».

Нажмите «Запустить приложения», затем прокрутите вниз до тех пор, пока не найдете настройку Bluetooth, установите галочку в поле и все сделанное.

ответил Mark Rooney 17 +04002011-10-17T01:13:01+04:00312011bEurope/MoscowMon, 17 Oct 2011 01:13:01 +0400 2011, 01:13:01

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132