Как установить «R» на OS X с помощью homebrew?

Как установить «R» на OS X? Идеально использовать Homebrew?

Кажется, что в Интернете мало информации.

81 голос | спросил matt burns 18 FebruaryEurope/MoscowbTue, 18 Feb 2014 16:15:15 +0400000000pmTue, 18 Feb 2014 16:15:15 +040014 2014, 16:15:15

7 ответов


114

Установить Homebrew (при необходимости)

  ruby ​​-e "$ (curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
 

Установить R

  варить кран доморощенный /наука
варить установку r
 
ответил matt burns 18 FebruaryEurope/MoscowbTue, 18 Feb 2014 16:15:15 +0400000000pmTue, 18 Feb 2014 16:15:15 +040014 2014, 16:15:15
28

Предполагая, что вы просто хотите установить â € œRâ € на OS X и не заинтересованы в доморощенном:

Просто загрузите двоичный файл из CRAN https://cloud.r-project.org/

  1. Перейдите к http://www.r-project.org/
  2. Нажмите CRAN
  3. Выберите зеркало
  4. Нажмите "загрузить R для (Mac) OS X"
  5. Загрузите и установите последнюю версию pkg

См. также R для часто задаваемых вопросов Mac OSX , которые содержит информацию об установке.

Обратите внимание также на приведенные ниже комментарии о том, что доморощенный часто не самый лучший вариант.

ответил Jeromy Anglim 18 FebruaryEurope/MoscowbTue, 18 Feb 2014 16:58:38 +0400000000pmTue, 18 Feb 2014 16:58:38 +040014 2014, 16:58:38
17

После выполнения ответа Matt Burns вы также можете установить GUI R.app через brew бочка :

  $ заварной кран /бочка
$ brew cask install r-app
$ open /Applications/R.app
 
ответил Josh Bode 28 MarpmFri, 28 Mar 2014 20:22:20 +04002014-03-28T20:22:20+04:0008 2014, 20:22:20
6

Вы можете скачать R для Mac OS X просто здесь: http://cran.cnr.berkeley.edu

Нажмите кнопку: Загрузить R для (Mac) OS X

Установите файл PKG, который был загружен.

Этот веб-сайт может помочь в продвижении и загрузке домашнего пива /установки домашнего варева.

https://github.com/Homebrew/homebrew/wiki/Инсталляция

ответил GummyArgyle 18 FebruaryEurope/MoscowbTue, 18 Feb 2014 17:04:21 +0400000000pmTue, 18 Feb 2014 17:04:21 +040014 2014, 17:04:21
2

Я поклонник RStudio . Это IDE, которая обертывает R, упрощает визуализацию, организацию, отладку и другие задачи much . Или вы можете просто использовать его, как если бы это была простая установка R. Существует бинарный файл Mac, доступный с этого веб-сайта.

ответил Brennon Bortz 20 FebruaryEurope/MoscowbThu, 20 Feb 2014 21:47:43 +0400000000pmThu, 20 Feb 2014 21:47:43 +040014 2014, 21:47:43
0

1.- http://cran.r-project.org/bin/macosx/ и скачать в Mac-GUI-1.62.tar.gz. 2.- УСТАНОВИТЬ

Вам необходимо создать и установить R в качестве рамки: см. «Установка R» и «Руководство по администрированию». Достаточно бинарной установки CRAN.

Здание R.app

Поддерживаются только Mac OS X 10.6 и выше и только 64-разрядные R. проект называется «R.xcodeproj» и требует Xcode 3.2 или выше.

Проект можно построить, выбрав «R» target и «Build» внутри графический интерфейс XCode.

Поддерживаемые конфигурации:   SnowLeopard64 (релиз, текущий OS X, по умолчанию)   Lion64 (выпуск, OS X 10.7+, Xcode 4.5+)   MLion64 (релиз, OS X 10.8+, Xcode 4.5+)   Отладка (с выходом отладки, текущая OS X)

Конфигурации отличаются в основном от выбранного SDK (последние версии Xcode поддерживают только текущие и сразу предыдущие SDK, поэтому например, в марте 2013 года значение по умолчанию составило бы 10,8, но конфигурация Lion64 позволяет строить для> = 10,7).

Чтобы создать проект из командной строки в каталоге Mac-GUI используйте что-то вроде:     xcodebuild -target R -конфигурация SnowLeopard64

Для создания R для Mac OS X FAQ используйте либо     xcodebuild -target Docs или вручную в папке документов     makeinfo -D UseExternalXrefs --html --force --no-split RMacOSX-FAQ.texi

Полученный файл html FAQ будет найден в каталоге Mac-GUI /docs.

Примечание о совместимости двоичных файлов:

Применяются общие правила для R, то есть двоичная совместимость только если основные и младшие номера версий совпадают - только патч уровень может отличаться. При использовании формы версии X.Y.Z это означает, что X.Y должен совпадать. Например, R-GUI, связанные с 3.0.x и 3.1.x, НЕ двоичная совместимость.

Скомпилированный R.app обычно связан с определенной версией, такой как 3.0.1. Если вы обновите R, удалив старую версию, скажем, используя R.app, построенный для версии 3.0.0 и обновляющий R до 3.0.1, вам может понадобиться исправить абсолютный путь к libR.dylib. Ночные сборки используют общий путь /Library/Frameworks/R.framework/Resources/lib/libR.dylib, которые указывают к последней версии R, но это делается путем дополнительного вызова install_name_tool в скрипте здания. Выпускать версии GUI используйте путь с фиксированной версией, поскольку они имеют определенную версию R (на самом деле поведение по умолчанию не зависит от GUI, а от libR.dylib - изменение его собственной ссылочной записи изменяет способ привязки R.app).

ответил YoelMacia 25 FebruaryEurope/MoscowbTue, 25 Feb 2014 09:46:39 +0400000000amTue, 25 Feb 2014 09:46:39 +040014 2014, 09:46:39
0

Я наткнулся на это, пытаясь установить R вообще, и я закончил использование MacPorts. Если вы используете MacPorts, попробуйте

  sudo port install R
 

Взято из http://johnlaudun.org/20140721-install-r-with -macports /

ответил Chris Smith 24 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowThu, 24 Sep 2015 07:22:12 +0300 2015, 07:22:12

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132