Как отключить режим приостановки?

Всякий раз, когда я оставляю свой малиновый пирог на ночь, он всегда, кажется, вступил в какое-то приостановленное состояние. Красный индикатор питания горит, но свет USB-устройства отключен, и я не могу получить доступ к нему с помощью SSH.

У меня нет периферийных устройств, кроме USB-устройства USB. Я просто использую его без звука как аудиоплеер.

Кто-нибудь знает, как полностью отключить любые функции приостановки?

39 голосов | спросил dgrant 27 J000000Friday12 2012, 08:13:08

4 ответа


52

Вы не представили много деталей, но я предполагаю, что вы используете адаптер WiFi с чипом Realtek 8192cu, поскольку это, как правило, используется. Mine - это то же самое, и я испытываю то, что, по моему мнению, та же проблема: когда вы покидаете RPi в течение длительного периода времени, Wi-Fi кажется отключенным, и вы больше не можете подключаться через SSH и т. Д.

Я искал решение для этого в течение нескольких месяцев и только сейчас нашел его здесь: https://github.com/xbianonpi/xbian/issues/217 . Решение для xbian, но это сработало для меня на Raspbian.

Проблема заключается в том, что адаптер имеет функции управления питанием по умолчанию. Это можно проверить, выполнив команду:

  cat /sys /module /8192cu /parameters /rtw_power_mgnt
 

Значение 0 означает, что отключено, 1 означает мин. управление питанием, 2 означает макс. управление энергопотреблением. Чтобы отключить это, вам необходимо создать новый файл:

  sudo nano /etc/modprobe.d/8192cu.conf
 

и добавьте следующее:

  # Отключить управление питанием
опции 8192cu rtw_power_mgnt = 0
 

Как только вы сохраните файл и перезагрузите свой RPi, Wi-Fi должен оставаться на неопределенный срок.

ответил Herohtar 16 Jpm1000000pmWed, 16 Jan 2013 13:09:40 +040013 2013, 13:09:40
3

Рекомендуемый ответ выглядит почти правильным, но некоторые дополнительные комментарии в исходной проблеме ( https: //github.com/xbianonpi/xbian/issues/217 ) предложит дополнительный вариант:

options 8192cu rtw_power_mgnt = 0 rtw_enusbss = 0

в /etc/modprobe.d/8192.conf , а не только rtw_power_mgnt = 0 . Просто указав, что один вариант не работает для меня, поскольку Wi-Fi все еще отключается.

ответил Talos 18 22014vEurope/Moscow11bEurope/MoscowTue, 18 Nov 2014 00:31:34 +0300 2014, 00:31:34
2

Моя проблема была заставка. Отключить со следующими командами:

Отключение экранной заставки:

  xset s off
 

Отключить другие функции энергетической звезды:

  xset -dpms
 

Это будет не работать на удаленном сеансе SSH

ответил Dan Power 30 J000000Tuesday13 2013, 05:05:03
1

GDM

Вы можете запретить GDM приостановить работу вашего компьютера, изменив значение в dconf-editor . Обратите внимание, что я сказал dconf-editor , not gconf-editor .

  $ dconf-editor
 

Теперь вам нужно перейти к узлу org.gnome.settings-daemon.plugins.power . Вы должны увидеть полный список пар ключ-значение. Измените следующие клавиши на следующие значения.

  • sleep-inactive-ac-type в ничего
  • спящий-неактивный тип аккумулятора в ничего

Ссылки

ответил 1 AM00000080000001131 2012, 08:39:11

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132