Почему мой символ @ не работает?

Я никогда раньше не использовал Linux, так что это может быть проблемой с этим, но я пытаюсь просто SSH на веб-сервере моих друзей, используя информацию, которую он мне дал. Я посмотрел, что команда linux для ssh - это ssh username @ hostname . Я не пытаюсь ввести это в LXTerminal, но каждый раз, когда я держу shift и нажимаю номер два, я не получаю @ Я получаю ". Любые идеи?

37 голосов | спросил EGHDK 13 J000000Friday12 2012, 21:06:27

4 ответа


46

Вам нужно переназначить клавиатуру. По умолчанию он установлен на карту Великобритании.

в командной строке:

  sudo nano /etc /default /keyboard
 

и нажмите enter. найдите следующую строку

  

XKBLAYOUT = â € gbâ €

Измените gb на нас (Это предполагает, что вы хотите сопоставить нас, если не замените gb на два буквенных кода для вашей страны)

и перезагрузите компьютер.

, если он долгое время приостанавливается во время этапа сопоставления клавиатуры, введите в командной строке следующее:

  sudo setupcon
 

Ваша следующая перезагрузка должна быть намного быстрее.

Ссылка:

http://elinux.org/index.php?title=R -Pi_Troubleshooting & амп; oldid = 147362 # Re-mapping_the_keyboard_with_Debian_Squeeze

ответил Steve Robillard 13 J000000Friday12 2012, 21:19:55
22

Ответ Стива, хотя и правильный в то время, теперь несколько устарел. В Raspbian:

  sudo raspi-config
 

и перейдите в раздел configure_keyboard с 4 Опции интернационализации -> I3 Изменение раскладки клавиатуры

Вы можете выбрать правильный тип клавиатуры и макет.

ответил scruss 18 Maypm13 2013, 20:16:17
1

Конфигурация малины Pi изменилась с Джесси (2017):

  1. raspi-config больше не предлагает Опции интернационализации . Опции Localization Options не имеют подменю для Изменить раскладку клавиатуры
  2. Просто настройка XKBLAYOUT = "us" может по умолчанию использовать испанский макет.

Это сработало для меня:

  sudo nano /etc /default /keyboard
 

И это были мои настройки (я канадский):

  XKBMODEL = "PC104"
XkbLayout = "ок"
XKBVARIANT = "рус"
 

Для наших южных соседей:

  XKBMODEL = "PC104"
XkbLayout = "нас"
XKBVARIANT = ""
 

Однако есть ошибка. Когда вы зарегистрируетесь

  Pi> Предпочтения> Конфигурация малины Pi
Pi> Предпочтения> Клавиатура и мышь.
 

он будет показывать Соединенные Штаты> Испанский (латиноамериканский). Я не думаю, что это влияет на функциональность.


Чтобы узнать нужную компоновку, запустите ее в терминале:

  rc_gui
 

Затем нажмите Локализация > Установить клавиатуру ... и внести изменения. Нажмите OK , чтобы закрыть диалоговое окно «Макет клавиатуры». Нажмите Установить клавиатуру ... еще раз. На этот раз в окне терминала вы увидите:

  Разделы: ['Global']
Макеты: ['ca']
Варианты: ['eng']
Опции: []
 

Теперь вы можете поместить их в свой

  sudo nano /etc /default /keyboard

Макеты -> XkbLayout
Варианты -> XKBVARIANT
 
ответил Colin 26 J000000Wednesday17 2017, 00:04:55
0

Другой вариант, который не использует терминал, входит (из графического интерфейса), Menu> Предпочтения> Конфигурация малины Pi> Локализация> Установите клавиатуру и установите ее в соответствии с тем, где вы живете.

ответил Dudesoftware 13 AM00000040000004131 2017, 04:09:41

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132