Adobe Flash Plugin уязвим /устарел в 14.04, но в Firefox нет обновления

Я использую Ubuntu 14.04 LTS. Когда я открываю сайт, для которого требуется Flash-плагин (например, Youtube), Firefox говорит Этот плагин уязвим и должен быть обновлен.

Снимок экрана

Однако, если я нажму Проверить наличие обновлений ... , обновления вообще нет. Это то, что обновить сайт :

  1. Shockwave Flash 11.2 r202 (статус обновлен 11.2.202.424)
  2. Плагин Java (TM) 11.25.2 (статус обновлен 11.25.2)

Итак, что мне делать?

57 голосов | спросил BornToCode 16 TueEurope/Moscow2014-12-16T14:44:53+03:00Europe/Moscow12bEurope/MoscowTue, 16 Dec 2014 14:44:53 +0300 2014, 14:44:53

11 ответов


52

Я провел некоторое исследование в mozilla и adobe и тесты с использованием последних версий LTS (14.04 и 12.04) и я уверен, что это просто проблема с номером флеш-плагина!

Короче говоря:
Если вы откроете в firefox «tools» - «add-ons» - «plugins», посмотрите на mozilla check и вы получили версию 11,2,202,425 (обратите внимание на запятые!), вы получите это сообщение об ошибке.
и если ваша версия 11.2.202.425 (такая же версия, только с точками в нумерации), все в порядке.

Так что не паникуйте, ваша система в безопасности! ; -)


Но я могу понять, что это сообщение раздражает, и поэтому это было бы самым простым способом избавиться от него:
откройте терминал и вставьте sudo apt-get update && sudo apt-get install -y flashplugin-installer, введите свой пароль root (символы не будут отображаться) и просто подождите, пока не будет выполнен!


Я бы рекомендовал это решение только в том случае, если вы уже установили последнюю версию, но все равно получите сообщение об ошибке из-за различий между flash-пакетами!

ответил DJCrashdummy 18 ThuEurope/Moscow2014-12-18T23:46:54+03:00Europe/Moscow12bEurope/MoscowThu, 18 Dec 2014 23:46:54 +0300 2014, 23:46:54
8

Следующее решение сработало для меня:

sudo apt-get purge flashplugin-installer
sudo apt-get install adobe-flashplugin
ответил Rambaldy 21 J000000Tuesday15 2015, 07:46:57
7

Лучшим решением проблемы уязвимой, устаревшей установки Flash - или даже самой современной, которая работает плохо - может быть полное удаление Flash полностью. Часто это не нужно, так как HTML5 в значительной степени перешла в прошлое. Таким образом, удаление Flash является реальным решением для многих людей и, вероятно, должно рассматриваться как first , прежде чем переходить к другим решениям, которые пытаются поддерживать Flash при сохранении в текущем (или полутоке) состоянии.

Как occupyflash.org говорит:

  

Flash Player мертв. Прошло время. Это глючит. Он сильно падает. Он требует постоянных обновлений безопасности. Это не работает на большинстве   мобильные устройства. Это ископаемое, оставшееся от эпохи закрытых   стандартов и одностороннего корпоративного управления веб-технологиями. Веб-сайты   которые полагаются на Flash, представляют собой совершенно непоследовательные (и часто   непригодный) опыт для быстро растущего процента пользователей, которые   не используйте браузер рабочего стола. Это вводит некоторую страшную   проблемы конфиденциальности с помощью файлов cookie Flash.

     

Flash делает Интернет менее доступным. В этот момент он удерживает веб-страницы.

ответил Jean Desjardins 7 PMpTue, 07 Apr 2015 19:47:10 +030047Tuesday 2015, 19:47:10
4

Как объявлено Adobe Adobe Flash Player 11.2 станет последней версией для Linux в качестве поддерживаемой платформы.

ответил sHAKaJaada 17 WedEurope/Moscow2014-12-17T00:10:08+03:00Europe/Moscow12bEurope/MoscowWed, 17 Dec 2014 00:10:08 +0300 2014, 00:10:08
3

Основная проблема в этой ситуации - устаревшая версия Flash Player в Firefox, что составляет 11,2
В то же время пользователи Google Chrome пользуются последней версией, поддерживаемой Google.

Трюк заключается в том, чтобы переключить Firefox с его Flash Player на Pepper Flash Player из Google Chrome.

  1. Прежде всего, удалим, что у нас есть:

      

    sudo apt-get удалить flashplugin-installer
      sudo apt-get удалить adobe-flashplugin

  2. Установите плагин Fresh Player Ринат Ибрагимов .
    Это оболочка, которая позволяет пользователям Linux использовать Pepper Flash (в комплекте с Google Chrome) в Firefox и других совместимых с NPAPI веб-браузерах.
    Последняя версия на данный момент составляет 0,3.1, и все кажется рабочим.

      

    sudo add-apt-repository ppa: nilarimogard /webupd8
      sudo apt-get update
      sudo apt-get install freshplayerplugin

  3. Установите Pepper Flash Player непосредственно из Google Chrome Stable:

      

    sudo apt-get install pepperflashplugin-nonfree
      sudo update-pepperflashplugin-nonfree --install

    Если вы хотите, вы можете установить флеш-плеер из разных версий:

    Бета Google Chrome:

      

    sudo update-pepperflashplugin-nonfree -install -beta -unverified

    Google Chrome нестабильно:

      

    sudo update-pepperflashplugin-nonfree -install -unstable -unverified

Теперь пришло время проверить версию:

  1. Adobe About показывает, что у меня есть 18,0,0,209
  2. about: addons показывает, что у меня есть версия 13.1 r2
  3. Mozilla Check Your Plugins показывает, что у меня есть версия 13.1.2.3, она устарела и предлагает обновление сейчас, но обновление не работает (и нам это действительно не нужно)
ответил Kirill Simonov 15 J000000Wednesday15 2015, 08:21:38
1

Это не проблема только с Ubuntu, потому что одно и то же сообщение появляется в FF на Mageia и openSUSE,

Решение - простая установка плагина для Pepper Flash для Firefox, Команда SUSE выпустила плагин на прошлой неделе, как только возникла проблема, так что на openSUSES flash будет 16,0, как в Chrome

Я надеюсь, что есть PPA для Ubuntu

http: //www.webupd8. орг /2014/05 /установки-свежий-плеер-плагин-в-ubuntu.html

p.s: последняя 11.2 вспышка действительно устарела (уязвима), изменение версии с apt-get не решит проблему

ответил gnash 25 ThuEurope/Moscow2014-12-25T19:36:44+03:00Europe/Moscow12bEurope/MoscowThu, 25 Dec 2014 19:36:44 +0300 2014, 19:36:44
0

В настоящее время я не могу воспроизвести вашу ошибку, но это должно решить вашу проблему:

откройте терминал и вставьте sudo apt-get update && sudo apt-get install adobe-flashplugin, введите свой пароль root (никакие символы не будут отображаться), подтвердите диалог и это будет!
ну ... может быть, вам нужно перезапустить браузер!

ответил DJCrashdummy 16 TueEurope/Moscow2014-12-16T15:36:31+03:00Europe/Moscow12bEurope/MoscowTue, 16 Dec 2014 15:36:31 +0300 2014, 15:36:31
0
  1. Доступ https://get.adobe.com/flashplayer/
  2. Выберите «Apt for Ubuntu 10.04+» в «Ваша система:
  3. Открыть с помощью приложения для обновления программного обеспечения
  4. Установите ..

Забудьте о шагах выше ... Он будет обновлен старой версией плагина Flash. Так что это не сработает. Новые рабочие шаги:)

  1. Доступ https://get.adobe.com/flashplayer/
  2. Выберите «.tar.gz для другого Linux»
  3. Подождите, пока загрузка не завершится.
  4. Извлеките libflashplayer.so в папку "~ /.mozilla /plugins" для вашего пользователя. Для всех пользователей вы должны извлечь в папку /opt /firefox (требуется разрешение root).

Сделал ли это последние шаги, у меня больше нет этих скучных сообщений.

ответил FabricioFCarv 19 FriEurope/Moscow2014-12-19T00:22:03+03:00Europe/Moscow12bEurope/MoscowFri, 19 Dec 2014 00:22:03 +0300 2014, 00:22:03
-1

У меня была эта проблема на моем ноутбуке сегодня, которую я модернизировал в некоторый момент от Ubuntu 13.10.

Оказывается, проблема заключалась в том, что пакет adobe-flashplugin не имел обновлений, но это было связано с файлом /etc/apt/sources.list, имеющей ссылку на saucy для репозитория partner . Редактирование этого файла и изменение этих экземпляров saucy в файле на trusty, поскольку они должны были быть обновлены, а затем запуск apt-get update && apt-get upgrade разрешил новый adobe-flashplugin для установки.

ответил dobey 17 WedEurope/Moscow2014-12-17T00:19:02+03:00Europe/Moscow12bEurope/MoscowWed, 17 Dec 2014 00:19:02 +0300 2014, 00:19:02
-2

Следующая процедура деактивирует предупреждения для всех плагинов, так как эта ошибка связана с проблемой нумерации флеш-плагина, как указано в DJCrashdummy, вы должны внимательно следить за ней, возможно, возвращая изменения через месяц или около того, как только вспышка -plugin получить правильную нумерацию.

  1. В адресной строке введите: about:config
  2. Согласитесь аннулировать гарантию.
  3. Щелкните правой кнопкой мыши в любом месте списка ниже и выберите New > Boolean
  4. Скопируйте эту фразу в имя предпочтительности: extensions.blocklist.enabled
  5. По умолчанию переменная должна быть установлена ​​в значение false, если ее нет в списке, дважды щелкните ее, пока она не будет.
  6. Перезагрузите браузер

https://support.mozilla.org/en-US/questions/949746

ответил Javier López 20 SatEurope/Moscow2014-12-20T10:44:06+03:00Europe/Moscow12bEurope/MoscowSat, 20 Dec 2014 10:44:06 +0300 2014, 10:44:06
-3

Пробовал ли вы вводить это в терминале:

  sudo apt-get install freshplayerplugin 
  sudo apt-get install pepper 
  sudo apt-get install adobe-flashplugin 
  sudo dpkg --reconfigure -a

, и это может работать нормально.

ответил Michael 16 TueEurope/Moscow2014-12-16T16:29:47+03:00Europe/Moscow12bEurope/MoscowTue, 16 Dec 2014 16:29:47 +0300 2014, 16:29:47

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132