Trueecrypt 7.1a требует Mac OS X 10.4 или более поздней версии на Yosemite 10.10

После чтения статей о состоянии Truecrypt в феврале 2015 года я решил загрузить последнюю стабильную версию Truecrypt, которая позволяет полностью использовать Truecrypt: то есть версию 7.1a

  

7.2 версия, которую можно использовать только для просмотра, но не для создания новых томов TrueCrypt.

см. https://www.grc.com/misc/truecrypt/truecrypt.htm

Затем я продолжил установку этого на моем Mac, работая на Yosemite 10.10

Но я получил сообщение об ошибке «truecrypt 7.1a требует Mac OS X 10.4 или новее», см. ниже.

truecrypt 7.1a требует Mac OS X 10.4 или более поздней версии на Yosemite 10.10

Я предполагаю, что это просто ошибка школьника от разработчика команды Truecrypt, поскольку она считает, что 10.4 выше 10.10, или, может быть, это довольно Apple, которая испортила и amp; должен был последовательно использовать 2 цифры после точки (т. е. использовать 10,04, а не 10,4).

В любом случае, я не могу установить Truecrypt. Кто-нибудь нашел решение для этого?

69 голосов | спросил Adrien Be 21 FebruaryEurope/MoscowbSat, 21 Feb 2015 15:23:06 +0300000000pmSat, 21 Feb 2015 15:23:06 +030015 2015, 15:23:06

3 ответа


116
  1. Скопируйте mpkg из загруженного образа диска на рабочий стол.
  2. Щелкните правой кнопкой мыши файл mpkg и выберите «Показать содержимое пакета», затем откройте папку «Содержание».
  3. Откройте файл distribution.dist с помощью текстового редактора.
  4. Удалите строки с 13 по 18.

  5. Сохраните файл и обычно откройте mpkg.

ответил grg 21 FebruaryEurope/MoscowbSat, 21 Feb 2015 15:35:56 +0300000000pmSat, 21 Feb 2015 15:35:56 +030015 2015, 15:35:56
0

На шаге 4. почему бы просто не исправить строку 13 ошибок как:

if (! (system.version.ProductVersion> = '10 .04.0 ')) {

и др.

ответил Patrick Bussi 2 J0000006Europe/Moscow 2018, 12:25:40
-1
  • Откройте терминал и введите sudo nano /System/Library/CoreServices/SystemVersion.plist
    и введите пароль администратора.
  • Измените две строки «10.10» на «10.9». Оставьте младший номер версии (например, 0, 1, 2 ...), как есть. Нажмите ctrl O и Введите , чтобы записать файл на диск.
  • Нажмите ctrl X , чтобы выйти из nano
  • Оставьте открытым окно терминала.
  • Установить TrueCrypt 7.1a
  • после завершения установки изменится на Terminal и снова введите sudo nano /System/Library/CoreServices/SystemVersion.plist
  • Измените две строки «10.9» на «10.10». Нажмите ctrl O и Введите , чтобы записать файл на диск.
  • Нажмите ctrl X , чтобы выйти из nano
  • введите cat /System/Library/CoreServices/SystemVersion.plist, чтобы проверить правильную версию системы (например, 10.10.2 или что бы это ни было).
ответил klanomath 21 FebruaryEurope/MoscowbSat, 21 Feb 2015 16:06:13 +0300000000pmSat, 21 Feb 2015 16:06:13 +030015 2015, 16:06:13

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132