Как обновить все до Twitter Bootstrap 3?

Я сделал шаблон, который использовал Twitter Bootstrap 3, и передняя часть работала нормально, пока у меня не было представлений редактирования в интерфейсе, которые сильно зависят от Twitter Bootstrap 2 из-за того, как Joomla была с версии 3, я пришлось отменить мои стили в Twitter Bootstrap 2, чтобы он работал правильно в краткосрочной перспективе.

Как я могу обновить все до Twitter Bootstrap 3 и удалить зависимости до версии 2?

8 голосов | спросил jackJoe 24 PMpThu, 24 Apr 2014 14:24:47 +040024Thursday 2014, 14:24:47

6 ответов


4

Не уверен, но используйте это расширение romplacer joomla

ссылайтесь на эту ссылку,

http://www.nonumber.nl/extensions/rereplacer

в противном случае, переопределение шаблонов - единственный способ сделать это.

ответил kumarramalingam 24 PMpThu, 24 Apr 2014 19:50:44 +040050Thursday 2014, 19:50:44
6

Переопределение шаблонов - единственный способ сделать это. Что касается полей формы, мы работаем над созданием JLayouts для этих полей формы, чтобы вы могли переопределить их (см. https: //github.com/joomla/joomla-cms/pull/3231 ).

Однако в настоящее время, как @Anibal говорит, что это невозможно в J3.2.

ответил George Wilson 24 PMpThu, 24 Apr 2014 15:49:13 +040049Thursday 2014, 15:49:13
4

Посмотрите этот шаблон администратора - это Isis преобразован в Bootstrap 3. Может быть, вы можете взять некоторые идеи оттуда. Кроме того, этот шаблон поддерживает как Bootstrap 2 & 3.

ответил Dmitry Rekun 24 PMpThu, 24 Apr 2014 16:53:43 +040053Thursday 2014, 16:53:43
2

В настоящее время это невозможно (J 3.2). Bootstrap v2.3.2 находится в ядре Joomla 3.

ответил Anibal 24 PMpThu, 24 Apr 2014 14:37:07 +040037Thursday 2014, 14:37:07
0

ОБНОВЛЕНИЕ: Я протестировал метод ниже и столкнулся с проблемами. Я бы не рекомендовал его.

Попробуйте использовать адаптер начальной загрузки. Он не удаляет зависимости от Bootstrap 2 (BS2), но может помочь вам в решении вашей проблемы. Я не совсем уверен, как это работает, но я считаю, что он заменяет BS2 css стилями, совместимыми с BS3.

http://about.asika.tw/bootstrap3-adapter/

ответил TryHarder 29 +03002014-10-29T13:58:26+03:00312014bEurope/MoscowWed, 29 Oct 2014 13:58:26 +0300 2014, 13:58:26
0

Вот простой шаблон переопределяет. Вы можете сделать это с помощью простых шагов. Просто следуйте за прочитанным мной :) https://github.com/rakeshmali/joomla-bootstrap-v3-template

Если обнаружены какие-либо проблемы, просто зарегистрируйте их там, вы обязательно получите решение.

ответил Rakesh Mali 21 Jpm1000000pmThu, 21 Jan 2016 16:05:01 +030016 2016, 16:05:01

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132