Почему OS X хочет, чтобы я «обновился» от El Capitan до Yosemite Beta 4?

Это просто глупо:

 Снимок экрана

Если я попытаюсь принять (нет, я бы не стал с этим соглашаться), он просто говорит, что обновление недоступно. Итак, почему он просит меня понизить, и как я могу избавиться от этого?

16 голосов | спросил neu242 4 Jpm1000000pmMon, 04 Jan 2016 16:45:02 +030016 2016, 16:45:02

1 ответ


17

В App Store можно запутаться по нескольким причинам. Я нахожу его глупым, когда он запутан, но распутывающие вещи немного колючие и в большинстве случаев удаляют юмор: - (

Первым и, скорее всего, является то, что где-то в вашей файловой системе существует более старая версия установщика Yosemite, и в магазине появляется «обновление». Он не предназначен для случая, когда загруженное приложение затем устанавливает ОС и явно не предполагает, что установщик, который вы «обновляете», на самом деле не будет запущен, поскольку понижение рейтинга не происходит по дизайну на OS X.

Вот некоторые из ситуаций, в которых может помочь очистка кэшей, если вы не можете сами найти приложение и сжать /удалить /переместить его в папку, в которой Spotlight не индексирует ее:

Мой личный фаворит - отредактировать само приложение, чтобы удалить файлы _MASreceipt, указывающие, что приложение появилось из самого магазина Mac App Store:

ответил bmike 4 Jpm1000000pmMon, 04 Jan 2016 16:48:22 +030016 2016, 16:48:22

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132