Настройка Cisco Router 1841

Мне нужна помощь. Я новичок в использовании маршрутизаторов Cisco (что касается их настройки), так что простите меня, если это что-то простое, что я нахожусь в поиске или не понимаю.

У меня есть кабельный интернет из cox. Они указали IP-адрес ниже:

IP: 98.191.**.147 
DG: 98.191.**.129
SNM 255.255.255.224

IP-адрес - это IP-адрес, который будет подключать маршрутизатор к модему ISP. На стороне локальной сети у меня есть следующее:

IP address 10.0.4.1
DG 10.0.4.254
SNM 255.255.255.0

Что мне нужно сделать, это взять сеть 10.0.4 и сказать, что Интернет находится на сетевом адресе 98.191.**.147 и подключается к Интернет таким образом. Я смотрел некоторые видеоролики YouTube о том, как это сделать, но есть кое-что, что мне не хватает, и я не могу понять это.

Вот что я до сих пор:

У меня нет подключения к Интернету в 10-точечной сети.

Router#show ip interface brief
 Interface IP-Address OK? Method Status Protocol
 FastEthernet0/0 10.0.4.1 YES manual up up
 FastEthernet0/1 98.191.**.147 YES manual up up
 Vlan1 unassigned YES unset administratively down down
 Router#

вот и все остальное ...

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.4.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 98.191.**.147 255.255.255.224
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.4.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 98.191.**.147 255.255.255.224
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!

end

Обновленные изменения

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.4.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 98.191.**.147 255.255.255.224
 ip nat outside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 1 interface FastEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
access-list 1 permit 10.0.4.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!

end

startup config

!

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.4.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 ip address 98.191.**.147 255.255.255.224
 ip nat outside
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 1 interface FastEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 
!
ip flow-export version 9
!
!
access-list 1 permit 10.0.4.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Новое обновление от 6/17/16

Router#
Router#show running
Router#show running-config
Building configuration...

Current configuration : 753 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.4.254 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 98.191.**.138 255.255.255.224
 ip nat outside
 duplex auto
 speed auto
!
ip classless
!
ip http server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.0.4.0 0.0.0.255
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Router#

Я могу выполнить ping 98.191. **. 147 и получить 100% -ный успех, но я пытаюсь выполнить ping 10.0.4.55 (другой компьютер), я получаю 100% -ный сбой.

Другими словами, я получаю однонаправленный трафик

3 голоса | спросил Kelly 15 J0000006Europe/Moscow 2016, 18:29:00

1 ответ


5

Ваша локальная адресация является частной адресацией, и вы не можете перенаправить ее в Интернет. Вам нужно будет использовать NAT. Вы настроите интерфейс WAN как интерфейс external , а интерфейс LAN - как внутри . Затем вам необходимо определить перевод. Обычно вы хотите, чтобы исходный IP-адрес трафика изнутри (частный адрес) был переведен на ваш внешний адрес (общий адрес).

Пример:

interface FastEthernet0/0
 ip address 10.0.4.1 255.255.255.0
 duplex auto
 speed auto
 ip nat inside
!
interface FastEthernet0/1
 ip address 98.191.**.147 255.255.255.224
 duplex auto
 speed auto
 ip nat outside
!
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.0.4.0 0.0.0.255
!

Это будет преобразовывать исходный адрес любого трафика в сети 10.0.4.0/24 как ваш адрес WAN из 98.191.**.147. Таким образом, любой трафик ответа придет к вашему маршрутизатору и будет переведен обратно на правильный адрес в вашей локальной сети.

Кроме того, вам понадобится маршрут по умолчанию:

ip route 0.0.0.0 0.0.0.0 98.191.**.149

Изменить для вас обновление:

Используя NAT так, как вы, вы получите однонаправленное создание трафика. Внешняя сторона не может инициировать трафик внутри. Это связано с тем, что таблица NAT построена, поскольку трафик поступает изнутри наружу, но записи таблицы не существуют, если трафик возникает извне. Маршрутизатор не имеет ни малейшего представления о том, куда отправлять, внутри, трафик на внешний интерфейс. Как правило, это делается с помощью частной адресации внутри и публичной адресации снаружи, и частные адреса не могут использоваться в общедоступной сети. В любом случае.

Вероятно, ваш пинг извне достигает внутреннего хоста, но когда внутренний хост отвечает, ответ имеет адрес источника, переведенный на WAN-адрес маршрутизатора, поэтому внешний хост не видит ответа с адреса, который он пытается выполнить ping. Затем пинг не работает, хотя он работает.

ответил Ron Maupin 15 J0000006Europe/Moscow 2016, 18:40:31

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132