Выключить совпадение скобок в высоком тексте 2

У меня есть вопросы об отключении совпадающих скобок. Кто-нибудь знает, как отключить сопоставление скобок?

Пример:

Когда я набираю (, он автоматически добавляет ), становится ().

Это довольно хорошо для редактирования обычного текста. Но довольно раздражает при редактировании файлов clojure.

42 голоса | спросил Juanito Fatas 21 FebruaryEurope/MoscowbTue, 21 Feb 2012 06:57:43 +0400000000amTue, 21 Feb 2012 06:57:43 +040012 2012, 06:57:43

3 ответа


56

Установите это в настройках пользователя

"auto_match_enabled" : false
ответил Jasper Bekkers 8 MarpmThu, 08 Mar 2012 15:56:43 +04002012-03-08T15:56:43+04:0003 2012, 15:56:43
8

Вы можете переключить этот параметр, добавив привязку клавиш к «Предпочтениям> Ключевые привязки - Пользователь ".
например чтобы Ctrl + Shift + p переключить настройку, используйте:

{
    "keys": ["ctrl+shift+p"],
    "command": "toggle_setting",
    "args":
    {
        "setting": "auto_match_enabled"
    }
} 
ответил pelms 3 +04002012-10-03T16:27:27+04:00312012bEurope/MoscowWed, 03 Oct 2012 16:27:27 +0400 2012, 16:27:27
1

Похоже, вам нужно изменить autoMatchEnabled на false в соответствии с настройками типа файла, чтобы отключить автоматическое сопряжение. Подробнее об этом: http://www.sublimetext.com/docs/file-type -preferences

ответил Sam Rastin 22 FebruaryEurope/MoscowbWed, 22 Feb 2012 18:36:25 +0400000000pmWed, 22 Feb 2012 18:36:25 +040012 2012, 18:36:25

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132