Firefox 57 на малине pi

Я только что слышал о новом firefox «Quantum». В нем говорится, что он использует на 30% меньше ОЗУ. Так как pi имеет только 1 гб RAM, этот звук хорош. Кроме того, было бы неплохо иметь более новую версию firefox.

Итак, могу ли я установить Firefox на мой малиновый pi 3?

Спасибо!

4 голоса | спросил Finn Shadow 21 22017vEurope/Moscow11bEurope/MoscowTue, 21 Nov 2017 00:45:09 +0300 2017, 00:45:09

2 ответа


6

Нет, не для стандартного Raspbian или Ubuntu MATE

Из-за неразрешенная проблема с Firefox 55, новые версии Firefox (последние в настоящее время Firefox 58) не работают на стандартном Raspbian или Ubuntu MATE. Этот вопрос продолжается до настоящего времени. Я сам опробовал каждую новую версию на Ubuntu MATE.

В стандартном Raspbian лучшее, что вы можете сделать сейчас - это остаться с Firefox ESR, так как он все равно получит обновления для системы безопасности. Последняя совместимая с RPi версия ESR в настоящее время является Firefox 52.5.2 ESR.

На Ubuntu вы можете пойти с Firefox 45.0.2, или вы можете использовать 52.0.2 на свой страх и риск. Firefox 52.0.2 не получает обновлений безопасности и может быть уязвим для атак.

Однако, похоже, это обходное решение. Дополнительную информацию см. В ответе jdonald.

Я действительно хочу, чтобы проблема Firefox была решена навсегда. Однако это маловероятно, поскольку никто не хочет брать на себя ответственность за его устранение. (Вы можете сделать свое собственное исследование, если хотите.)

Надеюсь, это поможет!

ответил Jǝssǝ 21 22017vEurope/Moscow11bEurope/MoscowTue, 21 Nov 2017 13:10:28 +0300 2017, 13:10:28
0

По состоянию на 04 апреля 2018 года Firefox Quantum v58.0.1 (Aurora) доступен в файле sakaki- 64-битное изображение Gentoo (которое должно работать на Raspberry Pi 3B и 3B +). Из README:

  

Из-за проблем с лицензированием (в частности, соответствия bindist) Mozilla Firefox Quantum был распространен в своем выпуске разработчика - под названием «Aurora». Имейте в виду, что это приложение займет довольно много времени (от 20 до 30 секунд), чтобы начать с первого использования, так как оно устанавливает локальное хранилище в ~ /.mozilla /<...>.

     

Firefox работает, но иногда может чувствовать себя довольно медлительным на Pi. Чтобы улучшить его, включите конвейерную обработку fetch и улучшенный кеш-сервер через about: config; см. эти инструкции , а также здесь .

README кажется устаревшим, потому что Поддержка конвейеризации HTTP /1 была удалена в Firefox 54 .

Текущий Raspbian [2018-03-13] поддерживает Firefox 52 ESR (из-за Debian), но вы можете рассмотреть браузер Vivaldi , который использует меньше оперативной памяти, чем Chromium. Убедитесь, что вы установили chrome-codecs-ffmpeg-extra _ * _ armhf.deb, как описано здесь , иначе Вивальди не запустится.

8 мая 2018 года будет выпущен Firefox 60.0 ESR, поэтому давайте надеяться, что Debian добавит его в свой репозиторий (кажется, что возникают проблемы с библиотеками Rust). Вы можете следить за развитием Debian на https://mozilla.debian.net/

В Raspbian вы можете установить текущую версию ESR Firefox, используя следующие команды:

sudo apt-get update
sudo apt-get install firefox-esr
ответил fiery 20 PMpFri, 20 Apr 2018 18:52:05 +030052Friday 2018, 18:52:05

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132