Откуда мой вторичный IP-адрес?

My Pi сконфигурирован с помощью Arch для использования eth0 со статическим IP-адресом, настроенным в conf.d:

[[email protected] ~]$ cat /etc/conf.d/[email protected]

address=10.0.55.5
netmask=24
broadcast=10.0.55.255
gateway=10.0.55.254

Это работало лучше, чем любая другая конфигурация (например, netctl) для меня с нескольких недель. Единственное странное: он использует 2 IP-адреса. Когда я просматриваю свой диапазон сети, мой Pi появляется 2 раза: Я полагаю, что один со статическим IP 10.0.55.5, а другой был назначен моим DHCP (диапазон, установленный на маршрутизаторе: 10.0.55.50-150): 10.0.55.55

nmap также сообщает имя хоста только на адресе .55, поэтому http: //raspberry.local/ назначается до .55

папка my /etc /netctl пуста, за исключением папок по умолчанию ...

[[email protected] ~]$ ls /etc/netctl
    examples  hooks  interfaces

Он также правильно отвечает на 10.0.55.55!

Где хранятся другие конфиги? Спасибо!

[[email protected] ~]$ ifconfig
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 10.0.55.5  netmask 255.255.255.0  broadcast 10.0.55.255
    ether b8:27:eb:50:ec:f4  txqueuelen 1000  (Ethernet)
    RX packets 17227  bytes 1077447 (1.0 MiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 85328  bytes 127324380 (121.4 MiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

изменить Я думаю, что нашел что-то здесь:

[[email protected] ~]$ ip addr
    4: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:50:ec:f4 brd ff:ff:ff:ff:ff:ff
inet 10.0.55.5/24 brd 10.0.55.255 scope global eth0
   valid_lft forever preferred_lft forever
inet 10.0.55.55/24 brd 10.0.55.255 scope global secondary eth0
   valid_lft forever preferred_lft forever

sudo ip addr del 10.0.55.55/24 dev eth0 отключил второй IP-адрес, просто попробовал перезагрузку сейчас

- > нет, все еще есть 2 IP-адреса: /

4 голоса | спросил Gotschi 31 Jpm1000000pmFri, 31 Jan 2014 19:33:03 +040014 2014, 19:33:03

3 ответа


3

Это помогло мне:

update-rc.d dhcpcd disable
service dhcpcd stop
ip addr del %YOURS-SECOND-IP% dev ethX

И когда вы снова запустите малину pi, область глобального вторичного исчезнет.

ответил DeamonMV 28 J000000Tuesday15 2015, 16:14:17
3

Проблема была вызвана отдельной сетью dhcp @, лежащей в /etc/systemd/system/

Нет подсказки, откуда она взялась, но удаление этой проблемы решило мою проблему:)

ответил Gotschi 15 FebruaryEurope/MoscowbSat, 15 Feb 2014 16:43:06 +0400000000pmSat, 15 Feb 2014 16:43:06 +040014 2014, 16:43:06
2

Изменить /etc/dhcpcd.conf

Это случилось со мной тоже (albiet на Raspbian).
Если вы не хотите полностью отключить службу dhcpcd, вы можете добавить ее в /etc/dhcpcd.conf, чтобы сообщить ему о вашем статическом интерфейсе:

interface eth0
static ip_address=192.168.0.10/24   
static routers=192.168.0.1
static domain_name_servers=192.168.0.1 8.8.8.8

Это остановит его от захвата вторичного ip при перезагрузке.

( Справочник по ArchWiki )

ответил Hydraxan14 9 Maypm16 2016, 20:46:24

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132