Настройте Pi, но на мониторе ничего не отображается.

Я только что получил свой Pi сегодня (модель 512 МБ, сделай в Великобритании), и я до сих пор не смог ничего с этим сделать. Я подключил его к телевизору с помощью моего кабеля hdmi, подключил сверхпростую клавиатуру и включил его с зарядным устройством для мобильного телефона (которое обеспечивает 1A). 4-Гбайт SD-карта была загружена с помощью Raspbian wheezy image с этой страницы и последовала указаниям здесь , чтобы настроить его. Когда он включается, светодиод загорается, но на экране ничего не появляется. Что мне не хватает?

4 голоса | спросил Alex 5 12012vEurope/Moscow11bEurope/MoscowMon, 05 Nov 2012 08:50:47 +0400 2012, 08:50:47

3 ответа


7

Pi отобразит пустой экран, если он не может загрузиться с SD-карты - мой ведет себя точно так, как вы описали, если я попытаюсь загрузить его без вставленной SD-карты. Возможно, что-то не так с вашим изображением или оно не может быть записано на SD-карту правильно.

Самый простой способ проверить, является ли это вашей проблемой, - распаковать BerryBoot на Отформатированная SD-карта FAT32 и загрузите ее. Это быстро, легко, сложно испортить, и если он позволяет загружать, вы можете загрузить /установить Raspbian через wifi /ethernet /USB. В любом случае, если он загружается, вы знаете, что ваш Pi, вероятно, O.K.

Вам также может потребоваться проверить, что хэш SHA-1 загруженного вами изображения совпадает с отображаемым на веб-сайте, чтобы узнать, правильно ли он загружен. Если совпадение хэшей вы также можете попробовать переписать изображение на SD-карту; пробовать новую /другую SD-карту; или тестирование отображаемой карты на другом Pi или внутри виртуальной машины.

ответил Nathan Dunn 5 12012vEurope/Moscow11bEurope/MoscowMon, 05 Nov 2012 09:16:08 +0400 2012, 09:16:08
1

Проблема может быть с дисплеем HDMI. Вам нужно изменить настройки в файле конфигурации. обратитесь к этой ссылке - http://www.raspberrypi.org/phpBB3 /viewtopic.php F = 26 & амп;? Т = 5851

Надеюсь, что это поможет.

ответил darshshah 5 12012vEurope/Moscow11bEurope/MoscowMon, 05 Nov 2012 16:18:43 +0400 2012, 16:18:43
0

Пробовал ли вы использовать вход HDMI без адаптеров с вашего Pi на ваш экран. Мой не работал в первый раз, пока я не подключил его к порту HDMI. Я только должен был сделать это один раз, и теперь я могу использовать адаптер HDMI для VGA. Думаю, это, вероятно, нужно было настроить ...!

ответил Lorenzo Battilocchi 11 Maypm15 2015, 23:22:12

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132