Проблема с экраном Ethernet /WebServer: «сервер на 0.0.0.0». Любые предложения по его отладке?

2 голоса | спросил Ibrar Ahmed 10 Maypm16 2016, 19:57:20

3 ответа


1

Это то, что должно быть. Это называется INADDR_ANY. Прочтите вводный текст в сетях, и вы поймете, что это значит.

Если вы попытаетесь подключиться к указанному IP-адресу, вы увидите, что вы действительно можете подключиться.

ответил JayEye 10 Maypm16 2016, 20:56:24
1

Ардуино только сообщает, что он читает из модуля ethernet, а 0.0.0.0 - это то, что вы получаете, когда Arduino не подключен к нему. Это аппаратная проблема, вы либо не подключили провода правильно, либо что-то обжарено. Я думаю, что это также может произойти, если ваш кабель ethernet отключен.

Это абсолютно не означает, что ваш модуль принимает все подключения. Это будет так, если вы установите его таким образом, но вы, очевидно, ожидаете другого ip-адреса. Кто-то должен удалить этот ответ.

ответил Vladivarius 29 +03002017-10-29T16:44:37+03:00312017bEurope/MoscowSun, 29 Oct 2017 16:44:37 +0300 2017, 16:44:37
1

Если возможно, попробуйте запустить тот же код на идентичном Arduino. У меня была аналогичная проблема, и оказалось, что один из моих контактов ICSP был сожжен.

В отличие от других ответов здесь IP-адрес отображает правильное значение в Serial Monitor, даже если никто не подключен.

ответил SupAl 21 J0000006Europe/Moscow 2018, 15:41:49

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132