NX-OS: импорт уже зеркалированной конфигурации в профиль коммутатора

Я запускаю NX-OS версии 5.2 (1) N1 (5) на пару Nexus 5020s, которые являются зеркалами друг друга во всех смыслах и целях. После обновления ОС некоторые из конфигураций, которые находились внутри switch-profile, смогли выйти за его пределы. Помимо того, что форма не синхронизирована, это вызывает ряд других проблем, таких как неспособность изменять биты конфигурации (switchport trunk allowed vlan ...).

Пример конфигурации для обоих коммутаторов в паре VPC.

! Relevant pieces from: show running-config include-switch-profile

interface port-channel301
  speed 10000

interface Ethernet1/17
  channel-group 301 mode active


switch-profile PROFILE
  sync-peers destination 192.168.0.2 ! This is .2 on switch-2

  interface port-channel301
    description SERVER-1
    switchport mode trunk
    switchport trunk allowed vlan 10, 20, 30-50
    spanning-tree port type edge trunk
    vpc 301

  interface Ethernet1/17
    description PO301 - SERVER-1
    switchport mode trunk
    switchport trunk allowed vlan 10, 20, 30-50
    spanning-tree port type edge trunk

При попытке вернуть эту конфигурацию в профиль коммутатора просто запуск import interface port-channel301 приведет к сбою взаимного исключения в commit, так как конфигурация существует с обеих сторон.

Лучшее решение, которое я могу извлечь из Руководство по устранению неполадок NX-OS :

  1. Удалите строчку sync-peers destination как с коммутатора-1, так и с коммутатора-2.
  2. Импортировать нужную конфигурацию на обоих коммутаторах и совершить.
  3. Добавьте sync-peers destination назад.

Кажется, что это подвержено человеческой ошибке. Меня особенно беспокоит добавление строфы sync-peers destination. Не так много информации о том, что произойдет, если профили не совпадают и что делать в этом случае.

Это действительно лучший способ? Существуют ли какие-либо передовые практики, когда люди делают такой импорт? Что произойдет, если профили переключателей будут разными? Есть некоторые институциональные знания об этом, но не так много в официальной документации NX-OS.

3 голоса | спросил James Harr 16 +04002013-10-16T08:28:48+04:00312013bEurope/MoscowWed, 16 Oct 2013 08:28:48 +0400 2013, 08:28:48

1 ответ


5

Идентификатор ошибки, который вы нажимаете, вероятно, CSCuf56076 , который фиксирован в 6.0 (2) N2 (1). К сожалению, это лучшее решение этой проблемы. К счастью, это не влияет на трафик на коммутаторах.

Для отладки вы можете увидеть, какая часть конфигурации находится в глобальной базе данных:

show system internal csm info global-db seq-tbl

и какая часть находится в синхронизированной базе данных:

show system internal csm info switch-profile <switch-profile-name> cfgd-db seq-tbl

При удалении кода sync-peer вы должны убедиться, что оба коммутатора имеют одинаковую конфигурацию и что те же части конфигурации в профиле коммутатора. Затем повторно добавьте sync-peer.

Помните, что в зависимости от того, что именно происходит не так, эта ошибка может появиться после каждой перезагрузки коммутатора. Когда мы попали в эту ошибку, мы впервые выполнили исправление в середине ночи, чтобы убедиться, что не было простоев. После уверенности в том, что трафик не был затронут, мы посмели исправить эти проблемы в несколько более удобные часы дня (но все же рано утром), пока Cisco не выпустит версию, которая исправила это.

ответил Sander Steffann 26 +04002013-10-26T21:42:15+04:00312013bEurope/MoscowSat, 26 Oct 2013 21:42:15 +0400 2013, 21:42:15

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132