Установка 20+ операционных систем на Mac без виртуализации

Для научного проекта мне нужно установить эти операционные системы на свой Mac Pro.

Ловушка ...

Он должен запускаться на собственном оборудовании, не допускается виртуализация уровня 1 или 2.

Вот список ОС, которые мне нужно для загрузки (некоторые могут быть добавлены позже):

1. FreeDOS
2. Windows 95
3. Windows XP
4. Windows 7
5. Windows 10
6. Slackware
7. Debian
8. Ubuntu
9. Arch
10. Gentoo
11. Fedora
12. Xinu
13. Minix
14. FreeBSD
15. NetBSD
16. OpenSolaris
17. OS X v10.0
18. OS X v10.1
19. OS X v10.2
20. OS X v10.3
21. OS X v10.4
22. OS X v10.5
23. OS X v10.6
24. OS X v10.7
25. OS X v10.8
26. OS X v10.9
27. OS X v10.10
28. OS X v10.11

Может кто-нибудь сказать мне, возможно ли это с каким-то существующим загрузчиком для Mac или нет?

UPDATE: Эта система тестирования не должна иметь только 1 загрузчик . Например, у меня могут быть 2 или 3 USB-накопителя с разными загрузчиками, и системы будут установлены на разделы диска Mac Pro.

13 голосов | спросил John Doerthy 7 62015vEurope/Moscow11bEurope/MoscowSat, 07 Nov 2015 23:13:16 +0300 2015, 23:13:16

5 ответов


28

В зависимости от вашего Mac Pro следующие операционные системы должны запускаться (или нет). Я не включал в себя все продаваемые Mac Pro, но я попытался перечислить основные этапы разработки (например, различные EFI-архитектуры 32 бит и 64 бит):

                     MacPro1,1   MacPro3,1  MacPro5,1* MacPro6,1 
 1. FreeDOS            +/-         uc         uc         uc
 2. Windows 95          -           -          -          -
 3. Windows XP         ++          ++         ++          -
 4. Windows 7          ++          ++         ++          -
 5. Windows 8           -         (++)        ++         ++
 6. Windows 10          -         (++)       (++)        ++
 7. Slackware           +           +          +          +
 8. Debian              +           +          +          +
 9. Ubuntu              +           +          +          +
10. Arch                +           +          +          +
11. Gentoo              +           +          +          +
12. Fedora              +           +          +          +
13. Xinu                -           -          -          -
14. Minix              uc          uc         uc         uc
15. FreeBSD           +/-          uc         uc         uc
16. NetBSD            +/-         +/-        +/-         uc
17. OpenSolaris         +         +/-        +/-         uc
18. OS X v10.0          -           -          -          -
19. OS X v10.1          -           -          -          -
20. OS X v10.2          -           -          -          -
21. OS X v10.3          -           -          -          -
22. OS X v10.4         ++           -          -          -
23. OS X v10.5         ++          ++          -          -
24. OS X v10.6         ++          ++         ++          -
25. OS X v10.7         ++          ++         ++          -
26. OS X v10.8          -          ++         ++          -
27. OS X v10.9          -          ++         ++         ++
28. OS X v10.10         -          ++         ++         ++
29. OS X v10.11         -          ++         ++         ++

-: doesn't run  ++: officially supported (++): runs probably +: runs maybe one/two drivers missing
+/-: some drivers missing  uc: unclear  *Newer MacPro5,1s probably can't run 10.6 

Я собрал этот список из разных источников и, вероятно, не завершен. Я присвоил второстепенные номера версий OS X (например, MacPro1,1 нуждается не менее 10.4.7). Некоторые записи хорошо финансируются (например, Microsoft и Apple OS), другие - из моего собственного опыта или интернет-источников. A + или +/- не обязательно означает, что легко получить систему, установленную /загруженную. Я приветствую изменения более знающих людей.


Приложение:

Я нашел два компьютерных вида, которые, вероятно, запускают все эти системы, второй, однако, пропускает видеокарту - и обе они, очевидно, не Mac Pros:

 введите описание изображения здесь>> </a> </p>

<p> <a href= введите описание изображения здесь>> </a> </p>

<p>; -) </p></body></html>

ответил klanomath 8 72015vEurope/Moscow11bEurope/MoscowSun, 08 Nov 2015 00:22:21 +0300 2015, 00:22:21
16

Это невозможно сделать на аппаратном уровне

Mac OS 10.0 - 10.3 работает только на компьютерах PowerPC. 10.4 и 10.5 могли работать на обоих (у 10.4 были отдельные версии для двух платформ, но 10.5 использовали единую установку). 10.6 и более поздние версии могут работать только на процессорах Intel. Таким образом, нет компьютера, который может работать как 10.3, так и 10.6. Кроме того, 10.7 поддерживает только 64-разрядные процессоры Intel (хотя многие его компоненты включают в себя как 32-, так и 64-разрядные двоичные файлы), а для 10.8 также требуется 64-разрядная прошивка EFI.

Нет Mac может запустить ОС старше себя - аппаратного обеспечения не существует для записи драйверов для него.

Даже в виртуальной машине нет ОС до 10.7 [возможно, 10.5 /10.6 сервер iirc, но не не сервер] лицензирован для виртуальной машины.

Boot Camp для запуска Windows - нет Mac, достаточно старого для запуска Windows XP, может запускать Windows 10, потому что Boot Camp сам ограничивает, какая ОС может быть установлена.

Для вариантов Unix я приглашаю изменения ...

ответил Tetsujin 7 62015vEurope/Moscow11bEurope/MoscowSat, 07 Nov 2015 23:33:37 +0300 2015, 23:33:37
4

Помимо проблем, которые возникли у других, с более ранними операционными системами Microsoft вы столкнетесь с проблемой, что им требуются жесткие диски с поддержкой MBR, которые поддерживают максимум четыре раздела. Возможно, вы сможете обойти это с помощью нескольких жестких дисков или физически заменить жесткие диски.

Вы также можете столкнуться с проблемами с очень старыми версиями Windows, которые могут потребовать оборудования, которое ваш Mac больше не включает. Однако я не могу придумать конкретный пример.

ответил Kevin Keane 8 72015vEurope/Moscow11bEurope/MoscowSun, 08 Nov 2015 09:32:19 +0300 2015, 09:32:19
1

В Minix может возникнуть проблема с поддержкой аппаратного обеспечения. Прежде всего - вы говорите об оригинальном Minix из книги Эндрю Танненбаума или о последней итерации?

Согласно http://wiki.minix3.org/doku.php? id = usersguide: hardwarerequirements для этого требуется компьютер с BIOS (а не UEFI - хотя вы, видимо, можете использовать GRUB, чтобы обойти эту проблему) диск в стиле MBR. Я думаю, что последним может быть то, что может убить Minix для вас; насколько я знаю, все компьютеры Mac используют EFI.

Кроме того, количество поддерживаемых аппаратных средств довольно ограничено; например, имеется только 10 различных сетевых адаптеров. Возможно, вы не сможете получить доступ к сети.

ответил Kevin Keane 20 52015vEurope/Moscow11bEurope/MoscowFri, 20 Nov 2015 04:08:21 +0300 2015, 04:08:21
0

В настоящее время я являюсь владельцем Mac Pro 1,1 с двойной загрузкой OS X 10.11 (El Capitan) + Windows 10 x64. У меня не было проблемы с несовместимостью драйверов. Для достижения этой цели вам нужно сделать несколько изменений.

  1. Установить rEFInd
  2. Получите совместимый с Apple графический процессор, который можно запрограммировать с помощью «Apple ROM», чтобы запустить последнюю версию OS X + с загрузочным экраном в то же время, убедитесь, что карта GPU хорошо поддерживается всеми вашими дистрибутивами Linux (PS: не покупайте новую графическую карту Nvidia с новой архитектурой Maxwell)
  3. Запасной диск SATA (который вы будете использовать как «установочный диск». Мы не используем CD или USB для установки (OSX, Linux и Windows) из-за несовместимости загрузки)
  4. VirtualBox (PS: VirtualBox будет использоваться для монтирования реального физического жесткого диска на виртуальную машину, где будет установлена ​​ваша операционная система Windows, чтобы иметь загрузочный раздел )
  5. UNetbootin (Чтобы создать всю вашу установку Linux «cd» на резервном диске SATA) .

Примечание. Если вы хотите, я могу сделать 3 учебника (простой и простой способ) , объясняющий, как

  1. Установите любую версию Linux на MacPro 1,1
  2. Как установить любую версию Windows на MacPro 1,1

и, наконец,

  1. Как установить любую версию OS X (последняя) на MacPro 1,1.
ответил Choleski Louis 27 Jpm1000000pmWed, 27 Jan 2016 22:47:41 +030016 2016, 22:47:41

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132