Использование адаптера Wi-Fi перезагружает Pi

Я использую Edimax EW-7811Un в моей малине Pi 2 под Raspbian. Версия Linux stickpi 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l (или, по крайней мере, это самое близкое, что я могу найти).

Каждый раз, когда один байт пытается пройти через адаптер, Pi перезагружается. В том числе, когда Pi извлекает часы реального времени при загрузке. Используя ifdown wlan0 и ifup wlan0, чтобы обновить DHCP однако не перезагружается.

Сеть, к которой я пытаюсь подключиться, настроена с паролем, который, я уверен, я ввел правильно, однако он требует дополнительного входа в систему через веб-браузер по причинам, которые, скорее всего, не входят в сферу действия этого вопроса - простой акт подключения к которому также вызывает перезагрузку.

Ethernet-соединение не работает до ~ 4: 30 PM в восточном направлении, но при необходимости я могу переправлять файлы с помощью флэш-накопителя.

Я бы не знал, насколько это важно для диагностики, но адаптер и порт USB нагрелись во время моих попыток исправить это сам. Переключение на другие порты не помогает.

4 голоса | спросил sctjkc01 17 MarpmTue, 17 Mar 2015 16:06:40 +03002015-03-17T16:06:40+03:0004 2015, 16:06:40

2 ответа


7

Это звучит как проблема с питанием. Является ли ваш источник питания достаточно сильным, чтобы поставлять как Pi, так и WiFi-адаптер?

ответил Werner Kvalem Vesterås 17 MarpmTue, 17 Mar 2015 16:14:36 +03002015-03-17T16:14:36+03:0004 2015, 16:14:36
0

У меня была проблема с моей малиной PI A + и с тем же адаптером.

Система будет загружаться до тех пор, пока она не дойдет до точки, где она подключена к Wi-Fi, затем выключится и снова перезагрузится. Вот что сработало для меня:

  • Получите лучший адаптер. Это «официальный /правильный» способ сделать это. Часто задаваемые вопросы рекомендуют не менее 1200 мА, и я использую 1000 мА. Усовершенствованные адаптеры исправили проблему.

  • Попробуйте подключиться к чему-то еще. Мой порт USB 3.0 смог обеспечить достаточную мощность для адаптера WiFi.

  • Попробуйте использовать другой USB-кабель. Качество и длина вашего шнура важны. Мой 5-ти длинный кабель вышел из строя с адаптером 1000 мА, в то время как работал более короткий 3-х длинный кабель.

Все это было с A +, поэтому ваш пробег может отличаться.

Снова просмотрите FAQ о малине PI - это довольно информативно.

ответил Robbie Wxyz 17 MarpmTue, 17 Mar 2015 22:04:31 +03002015-03-17T22:04:31+03:0010 2015, 22:04:31

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132