Теги Dot1q, суб-интерфейсы

Пожалуйста, обратите внимание, что кадры dot1q помечены тегами 100, циркулирующие в локальной сети (VLAN 100).

Чтобы выйти в Интернет, кадры должны проходить через под-интерфейс PPPoE, который настроен следующим образом:

interface GigabitEthernet0/0/0.1
  encapsulation dot1Q 777
  pppoe enable group global
  pppoe-client dial-pool-number 1

Рамки, выходящие из локальной сети, выходят в Интернет, получают тег 777.

Можете ли вы объяснить, что происходит с фреймами с тегами 100, когда они проходят (или пытаются пройти) этот под-интерфейс Gi0 /0 /0.1?

Отбрасываются ли они?

Их тэг 100 заменен тегом 777?

Что с ними происходит?

Спасибо.

=============================================== ==============

РЕДАКТИРОВАТЬ 1 - в ответ Майку Пеннингтону

Спасибо за ваш ответ, который очень полезен.

Вы правы. У меня также есть интерфейс Dialer, настроенный, как вы говорите.

Учитывая то, что вы объясняете, я думаю, что мои кадры из VLAN 100 отброшены.

  

Таким образом, фреймы с меткой 100, входящие в этот маршрутизатор, выходят в Интернет, предполагая:

     

1) Они входят в маршрутизатор на другом субстрате IP vlan 100 или SVI

Создать другой суб-интерфейс:

interface GigabitEthernet0/0/0.100
  encapsulation dot1Q 100

Как насчет ссылки PPPoE и Dialer?

У меня может быть только одна ссылка PPPoE, и я предполагаю, что только один интерфейс Dialer.

  

2) У них есть MAC-адрес назначения вышеупомянутого   субинтерфейс

Как я могу сказать, что кадры dot1q с тегами 100 должны проходить через этот суб-интерфейс с его конкретным целевым mac-адресом?

Есть ли ссылка, которая должна быть сделана между новым суб-интерфейсом GigabitEthernet0/0/0.100 и под-интерфейсом LAN GigabitEthernet0/0/1.100 который уже настроен и который настроен как:

interface GigabitEthernet0/0/1.100
 description ***Router sub-interface for voice traffic***
 encapsulation dot1Q 100
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
  

3) В маршрутизаторе есть маршрут, указывающий, что пункт назначения пакета   IP-адрес в Интернете

Не могли бы вы рассказать мне, как настроить этот маршрут?

Будет ли это путь от интерфейса GigabitEthernet0/0/1.100 к интерфейсу Dialer?

3 голоса | спросил Léa Massiot 9 J000000Monday18 2018, 16:16:07

1 ответ


3
  

Можете ли вы объяснить, что происходит с фреймами с тегами 100, когда они проходят (или пытаются пройти) этот под-интерфейс Gi0 /0 /0.1?

Во-первых, давайте немного подробнее расскажем о вашей конфигурации для других читателей. Скорее всего, у вас также есть интерфейс в маршрутизаторе, настроенный следующим образом:

interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname myUsername
 ppp chap password myPassword
 dialer-list 1 protocol ip permit
!

Таким образом, фреймы с меткой 100, входящими в этот маршрутизатор, будут выйти в интернет , если:

  • Они вводят маршрутизатор на другом субстрате IP vlan 100 или SVI
  • У них есть MAC-адрес назначения вышеупомянутого субинтерфейса
  • В маршрутизаторе есть маршрут, указывающий, что IP-адрес назначения пакета в Интернет
  

Их тэг 100 заменен тегом 777?

Если они направляются в интернет

  

Отбрасываются ли они?

Пакеты Vlan 100 будут удалены, если маршрутизатор не знает, что с ними делать. Большие пакеты UDP, выходящие в Интернет, будут фрагментированы, чтобы соответствовать MTU выходного интерфейса по мере необходимости.

ответил Mike Pennington 9 J000000Monday18 2018, 16:35:49

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132