Открытие двух мониторов на неправильном мониторе

Я новичок в ubuntu, использую его уже около месяца. Я создал этот рабочий стол для мифа tv, и поэтому я использую конфигурацию с двумя мониторами (один монитор для просмотра шоу и один для всего остального). Но поскольку у меня нет тюнера (пока), я просто использую hulu desktop и некоторые видеофайлы, которые у меня уже есть. Проблема в том, что когда я открываю некоторые приложения, такие как firefox, они открываются на мониторе, который воспроизводит видео. Иногда они даже открываются за видео-приложением. Есть ли способ прикреплять приложения к определенному монитору, чтобы он всегда открывался в этом приложении?

Я собирался опубликовать изображение экрана настройки экрана, но я буду новым для публикации изображений. Если вам нужно увидеть изображение, сообщите мне, и я отправлю его вам. изображение просто показало мои два экрана, 20 "справа, а один из них неизвестен слева. Кнопка« То же изображение во всех мониторах »не отмечена.

Самсунг - это монитор, на котором я хочу его открыть, а неизвестное - это телевизор, на котором я смотрю видео. Firefox, в частности, всегда открывается на телевизоре всякий раз, когда он был закрыт, пока он максимизирован, и открывается на экране, когда он был закрыт, когда он был закрыт, а не максимизирован. Это самое большое раздражение, которое у меня есть с ubuntu. Я прихожу к ubuntu с mac, и имею базовый опыт работы на уровне среднего уровня.

39 голосов | спросил chazwh 28 +04002010-10-28T08:14:08+04:00312010bEurope/MoscowThu, 28 Oct 2010 08:14:08 +0400 2010, 08:14:08

8 ответов


27

Если у вас нет CompizConfig, установите его (в любом случае вам это нужно). Перейдите в Менеджер настроек CompizConfig> Управление окнами> Разместите Windows (убедитесь, что этот плагин отмечен). На вкладке «Общие» вы увидите вариант «Режим многоканального вывода». У вас есть такие опции, как: использование активного устройства вывода или использование выходного устройства с указателем и т. Д.

ответил Vadim 12 Maypm11 2011, 23:03:47
10

Что-то похожее на это случилось со мной некоторое время назад. Попробуйте перейти к System> Предпочтения> Мониторы. Убедитесь, что главный монитор (ваш рабочий монитор) находится слева, а не справа. Если два монитора отличаются друг от друга, убедитесь, что оба они совпадают вверху. Я заметил это с моей установкой пару месяцев назад, когда я установил монитор, который использовал разрешение выше моего рабочего монитора.

ответил Jordon Bedwell 31 +03002010-10-31T09:34:41+03:00312010bEurope/MoscowSun, 31 Oct 2010 09:34:41 +0300 2010, 09:34:41
5

Другой выбор - использовать devilspie. Вы можете получить Devilspie из репозитория Universe.

ответил SpaceGhost 3 32010vEurope/Moscow11bEurope/MoscowWed, 03 Nov 2010 22:51:33 +0300 2010, 22:51:33
3

Я верю (если у вас включен compiz), что вы можете сделать это из менеджера настроек compiz, используя плагин windows windows. Я не делал этого сам, но если вы немного поиграете с параметрами, вы сможете получить окно, которое появится на нужном мониторе.

ответил RolandiXor 28 +04002010-10-28T21:24:13+04:00312010bEurope/MoscowThu, 28 Oct 2010 21:24:13 +0400 2010, 21:24:13
2

Я исправил его с помощью compiz-config-manager. установите с помощью

sudo apt-get install compizconfig-settings-manager

Перейдите в раздел Общие> Общие параметры> Настройки дисплея

Установить перекрытие вывода Обработка любого отображаемого вами изображения (чем меньше или больше, не уверены, что делать, если у вас есть мониторы одинакового размера?).

Правильная установка текстового поля «Выходы» с соответствующими разрешениями экрана, по-видимому, помогает лучше разместить окна.

ответил Gerard 15 MaramFri, 15 Mar 2013 05:26:33 +04002013-03-15T05:26:33+04:0005 2013, 05:26:33
2

В меню «Система» выберите «Мониторы». Установите флажок «Показывать мониторы в панели», затем щелкните по нужному монитору по умолчанию и нажмите кнопку «Сделать по умолчанию». Выйдите из системы и вернитесь туда, и там вы идете.

Я пробовал это несколько раз, и это никогда не делалось, пока я не проверил окно «Показать мониторы в панели».

ответил WebWeasel 7 AMpThu, 07 Apr 2011 06:37:01 +040037Thursday 2011, 06:37:01
0

Щелкните правой кнопкой мыши на заголовке окна и выберите: More Actions -▸ Window Manager Settings. В столбце слева выберите Focus. Toggle option Active screen follows mouse.

Если никаких других значений по умолчанию не указано, на текущем активном экране появятся окна. С описанной выше процедурой положение мыши определяет этот активный экран.

ответил BiberBb 25 PMpFri, 25 Apr 2014 20:05:58 +040005Friday 2014, 20:05:58
0

В «Дисплеях» с раскрывающимся меню «Размещение пусковой установки» выберите монитор, на который вы хотите открывать приложения.

ответил Aaron 16 SatEurope/Moscow2017-12-16T00:05:33+03:00Europe/Moscow12bEurope/MoscowSat, 16 Dec 2017 00:05:33 +0300 2017, 00:05:33

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132