PiFM не работает для меня

Я выполнил следующие шаги: здесь и amp; проконсультировался этот сайт . Но я просто получаю полное молчание на 100,1 или других частотах. Нет звука вообще.

Скажите, пожалуйста, что это значит. Я действительно хочу видеть & используйте мой Pi в качестве FM-передатчика.

4 голоса | спросил jonny789 21 42013vEurope/Moscow11bEurope/MoscowThu, 21 Nov 2013 18:14:38 +0400 2013, 18:14:38

5 ответов


1

Я столкнулся с этой проблемой с моей лабораторией «Малина Пи», где связано множество датчиков и т. д. Просто установите новый новый raspbian, сделайте обновления и обновления (sudo raspi-config) и повторите попытку. Это сработало для меня.

ответил syss 27 32013vEurope/Moscow11bEurope/MoscowWed, 27 Nov 2013 17:43:46 +0400 2013, 17:43:46
1

TL; DR: проблема исчезла после перезагрузки!

У меня также была эта проблема. Похоже, что он не будет правильно передаваться, если вы уже воспроизводили звук с динамика, подключенного к пи. FM снова работал после перезапуска, но перестает работать, если я воспроизвожу звук с пи.

ответил user211786 7 Jpm1000000pmTue, 07 Jan 2014 13:08:52 +040014 2014, 13:08:52
1

Проблема заключается в том, что pifm использует GPIO 4. Этот вывод также используется ядром. 1 проводные устройства должны отключить их в /etc /modules и, возможно, в raspi-config в Advance options. Дерево устройств затем запускает pifm, и оно должно работать.

ответил user34388 5 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowSat, 05 Sep 2015 00:54:50 +0300 2015, 00:54:50
1
  1. Убедитесь, что вы правильно идентифицировали вывод GPIO 4. Это 4-й вывод вниз (4-я строка) во внутреннем столбце.

  2. Если система сильно загружена, частота может быть плохо сдвинута или изменена. Убедитесь, что загрузка процессора низка и равна нулю (проверьте с «временем безотказной работы» или «сверху»).

  3. Вам почти наверняка нужно быть root (sudo или su) для доступа к контактам GPIO (через /dev /mem) [если вы уже не обратились к этому как-то, например, через set user ID).

  4. Настоятельно рекомендуется добавленная проволочная антенна. Без этого вы можете не получить сигнал.

  5. Если у вас были другие процессы, которые использовали GPIO с момента последней перезагрузки, они могли быть настроены неправильно. Это может произойти несколькими способами. Видеть: http://sourceforge.net/p/raspberry-gpio-python/wiki/BasicUsage для основного плана проблем.

Трудно узнать, какая из этих проблем - проблема, но я думаю, что это корневой доступ или отсутствие антенны. Удачи!

ответил dudek 5 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowSat, 05 Sep 2015 05:57:42 +0300 2015, 05:57:42
1

Для меня проблема была в распространении Raspbian. Итак, я загрузил последние Raspbian с сайта. Затем PiFM работал красиво.

ответил jonny789 21 stEurope/Moscowp30Europe/Moscow09bEurope/MoscowMon, 21 Sep 2015 13:13:17 +0300 2015, 13:13:17

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132