Как отключить микрофон от автоматической регулировки уровня входного сигнала

Я хочу отключить способ понижения микрофона в зависимости от входа. Вот изображение:

введите описание изображения здесь>> </p>

<p> Микрофон начинал со 100% и медленно начинал падение до места, где отображается изображение. Это происходит из-за фонового шума или пользователя, повышающего голос. В любом случае я бы хотел запретить это поведение, потому что, когда он становится слишком низким, потребность в повышении голоса будет действительно необходима. </p>

<p> Итак, есть ли опция или файл конфигурации, где можно редактировать и изменять это поведение? </p>

<p> Это не относится только к одному приложению, кроме нескольких, от Skype до Google Hangouts, Empathy to Teamspeak и других. Поэтому, пожалуйста, никаких ответов не упоминается только в одном приложении, если решение не решит проблему для других. </p>

<p> приложение pulseaudio (gui и terminal) уже использовалось. Также использовался Alsamixer. В обоих случаях настройка уровня микрофона не помогла. Автоматическая настройка всегда происходит, когда кто-либо говорит, даже не нужно, чтобы кто-то говорил громко, им просто нужно было говорить, и через пару секунд уровень микрофона начнется автоматически. Повторяю, это не проблема с 1 приложением, а несколько, поэтому общее решение лучше, чем 1 для каждого приложения (о котором мы говорим о более чем 50 приложениях). </p></body></html>

38 голосов | спросил Luis Alvarado 9 AMpTue, 09 Apr 2013 06:32:17 +040032Tuesday 2013, 06:32:17

9 ответов


21

Для Skype:

Skype> Опции> Звуковые устройства
и снимите флажок Разрешить skype автоматически настраивать уровень микшера

ответил selvan 4 ThuEurope/Moscow2014-12-04T09:31:42+03:00Europe/Moscow12bEurope/MoscowThu, 04 Dec 2014 09:31:42 +0300 2014, 09:31:42
14

Не уверен, что это относится ко всем, но если вы используете какой-либо сервис веб-конференции /видеочата в Chrome /Chromium, такой как Google Hangouts, есть хороший шанс, что он использует протокол WebRTC. К сожалению, реализация WebRTC в Chromium поставляется с удобной «функцией» под названием Automatic Gain Control, которая имеет тенденцию к шуму с объемом вашего микрофона. Если веб-приложение не дает вам возможность отключить его, в противном случае нет способа отключить его, а Разработчики Chrome не хотят добавлять для него глобальный« выключенный переключатель ».

В результате я решил использовать решение @ lelandbatey. Поскольку я использовал PulseAudio, я использовал pacmd вместо amixer:

while sleep 0.1; do pacmd set-source-volume alsa_input.???-?????.analog-stereo 90000; done

Обратите внимание, что 65535 соответствует 100%, поэтому 90000 составляет около 135%. Имя устройства (alsa_input.???-?????.analog-stereo) должно быть заменено всем, что вы найдете, запустив pacmd list-sources | grep name::

name: <alsa_input.???-?????.analog-stereo>
ответил Rufflewind 26 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowMon, 26 Sep 2016 21:50:34 +0300 2016, 21:50:34
7

Установите микрофон на Unamplified 100% Попробуйте установить управление громкостью пульсового звука:

sudo apt-get install pavucontrol

И затем откройте: pavucontrol

ответил Marcela Oniga 24 FebruaryEurope/MoscowbMon, 24 Feb 2014 21:33:47 +0400000000pmMon, 24 Feb 2014 21:33:47 +040014 2014, 21:33:47
5

Я все еще работаю над этой раздражающей проблемой (опция должна быть включена на вкладке «Устройства ввода», чтобы «принудительно» вводить тома, чтобы оставаться там, где пользователь хочет ее установить. Это применимо к конкретным случаям, когда пользователь знает, что объем, необходимый для конкретного приложения, и функции автоматической настройки не работают должным образом. В любом случае, чтобы настроить его в «полуавтоматическом» режиме вместо автоматической настройки для Google Apps, таких как Hangouts, созданы /изменены параметры файла в:

nano ~/.config/google-googletalkplugin/options

и добавьте строку:

audio-flags=1

или просто запустите следующую строку:

echo "audio-flags=1" > ~/.config/google-googletalkplugin/options

Сохраните файл и закройте все приложения Google. Объем для устройства ввода должен прекратить автоматическую настройку. Это работает 50/50, поэтому я ищу постоянное решение.

ответил Luis Alvarado 10 12014vEurope/Moscow11bEurope/MoscowMon, 10 Nov 2014 04:26:52 +0300 2014, 04:26:52
2

У меня возникла эта проблема со Skype, вам нужно отключить автоматическую настройку уровней микшера (возможно, вам нужно проверить дополнительные настройки или что-то подобное)

ответил lanodan 27 FebruaryEurope/MoscowbThu, 27 Feb 2014 19:10:14 +0400000000pmThu, 27 Feb 2014 19:10:14 +040014 2014, 19:10:14
2

У меня была эта проблема, но с каждым типом видеочата, который я попытался использовать на Xubuntu, все, что от Google Hangouts до appr.tc, автоматически отрегулировало бы громкость микрофона. В частности, он, кажется, увеличивает громкость, если любые голоса могут быть услышаны в фоновом режиме, как если бы можно было услышать самый тихий голос.

В любом случае, мое исправление заключалось в том, чтобы вручную установить громкость микрофона с помощью директивы командной строки, вставить цикл while и запустить каждую десятую секунды. Итак, вот оболочка oneliner, которая решает мою проблему:

while true; do amixer -c 1 set 'Mic Boost' 0db > /dev/null; amixer -c 1 set 'Capture' 35db > /dev/null;  sleep 0.1; done;

На вашем компьютере, чтобы заставить его работать, вам может потребоваться изменить какое устройство настроить и какие каналы изменить. Чтобы найти эту информацию, вы можете использовать микшер Alsa, доступный с помощью alsamixer.

ответил lelandbatey 5 FebruaryEurope/MoscowbFri, 05 Feb 2016 07:40:41 +0300000000amFri, 05 Feb 2016 07:40:41 +030016 2016, 07:40:41
2

Это сработало для нас (мы не пользуемся Skype):

https://nzeid.net/pulseaudio-disable-auto-volume

# Disable auto adjusting of gain on mic:
# Edit as root: /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf
# Edit as root: /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf
# Under "[Element Internal Mic Boost]" set "volume"  to "zero".
# Under "[Element Int Mic Boost]" set "volume"  to "zero".
# Under "[Element Mic Boost]" set "volume"  to "zero".
ответил nh2 19 FebruaryEurope/MoscowbFri, 19 Feb 2016 16:47:21 +0300000000pmFri, 19 Feb 2016 16:47:21 +030016 2016, 16:47:21
2

Я исправил проблему на своей машине, отключив любые другие микрофоны на моем рабочем столе. Я обнаружил, что если микрофон камеры поднял звук, он снизил коэффициент усиления на гарнитуре. Я отключил микрофон камеры, и гарнитура теперь устойчива.

Не уверен, что это помогает, но подумал, что стоит упомянуть.

ответил Andy Thornton 20 thEurope/Moscowp30Europe/Moscow09bEurope/MoscowTue, 20 Sep 2016 16:53:14 +0300 2016, 16:53:14
1

Ответ от этого «дублированного» вопроса для меня лучший, я дал кредиты тому, кто ответил

В конфигурационном файле /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf (возможно, вам придется искать правильный файл для вашего микрофона), я изменил volume = part to 100, который представляет собой процент вместо ---- +: = 3 = + ----

merge

to

[Element Capture]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

, а после [Element Capture] switch = mute volume = 100 override-map.1 = all override-map.2 = all-left,all-right приложения больше не изменяют громкость микрофона.

ответил Philippe Gachoud 6 Maypm17 2017, 18:10:17

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132