Область администрирования постоянно перенаправляется на главную страницу

У меня возникла проблема с доступом к сайту администратора ... Я слишком много искал Google и пробовал каждое предложение, упомянутое на этих сайтах .. но никто из них не работает: S ..

Перейдя на mysite.com/administrator, он перенаправляет меня на сайт site.com/homepage (страница пользователя).

Когда я перехожу к плагинам, я вижу, что там установлен «JhackGuard» ... Я попытался переименовать с php на .bak, но все еще не работает ...

Любое предложение

php
1 голос | спросил h0feer 27 J000000Monday15 2015, 14:13:39

4 ответа


2

Вы пытались отключить плагин через базу данных? В таблице «prefix_extensions» в столбце «enabled» просто замените 1 на 0. Он работает для аналогичных расширений.

ответил romaster 27 J000000Monday15 2015, 14:29:32
1

Если вы действительно отключили плагин в базе данных, но ваша область администрирования по-прежнему перенаправляет вас, вы можете попробовать очистить кеш браузера. В некоторых случаях Chrome, Explore и Safari сохраняются с переадресацией ...

ответил Max 26 PM00000040000004131 2015, 16:49:41
1

в этой таблице "prefix_extensions" под названием столбца name "и выполните поиск" JHackGuard Plugin "в столбце" enabled "заданное значение для 0.

это отключит плагин.

Я также перехожу в столбец «name» и поиск значения «com_jhackguard» в столбце "params"
Я изменяю это:

{"enabled":"1","log_level":"1","log_garbage_collection":"7","license_key":"free-version","admin_protection":"1","admin_keyword":"admin","disable_uploads":"1","scan_uploads":"1","use_cymru":"1"}

:

{"enabled":"1","log_level":"1","log_garbage_collection":"7","license_key":"free-version","admin_protection":"0","admin_keyword":"","disable_uploads":"1","scan_uploads":"1","use_cymru":"1"}
ответил sarah 12 J000000Tuesday16 2016, 17:16:58
1

У меня была такая же проблема, когда я переношу сайт на другой сервер. Ссылка администратора - http://website.com/administrator/index.php перенаправить на http://website.com из-за некоторых проблем с плагинами, но я не был уверен, какой плагин создает эту ошибку. Поэтому мне понравилось ниже

  1. Загрузите ту же самую версию Joomla здесь - https://downloads.joomla.org

  2. Распаковать /Извлечь его в новый каталог - "freshjoomla"

  3. В http://website.com в каталоге public_html переименуйте существующий каталог (в моем домашнем каталоге) is - /var/www/sites/website.com/public_html/)

    mv /var/www/sites/website.com/public_html/components/var/www/sites/website.com/public_html/components_old

    mv /var/www/sites/website.com/public_html/plugins/var/www/sites/website.com/public_html/plugins_old

Теперь скопируйте свежие компоненты и плагины из каталога freshjoomla

cp -vr freshjoomla/components /var/www/sites/website.com/public_html/
cp -vr freshjoomla/plugins /var/www/sites/website.com/public_html/

Теперь измените право собственности на компоненты, каталоги плагинов на имя пользователя службы веб-сервера

Большинство случаев - www-данные для nginx, apache для apache 2

chown -R www-data:www-data /var/www/sites/website.com/public_html/components
chown -R www-data:www-data /var/www/sites/website.com/public_html/plugins 

Теперь загрузите страницу администратора - http://website.com/administrator/index.php

Снова загрузите и установите необходимые плагины по одному.

ответил Sathish 20 J000000Friday18 2018, 10:35:54

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132