Динамик Bluetooth: предпочтительный режим «Воспроизведение с высокой точностью воспроизведения» (A2DP) не сохраняется

UPDATE Aug 2017: решение, помеченное как принятое мной apppears, работало до Ubuntu 15.10. Для 16.04+ выберите одно из последних решений.

Для 16.04+ конфигурационный файл /etc/bluetooth/main.conf NOT /etc/bluetooth/audio.conf.

У меня есть динамик bluetooth, Sony SRS-BTX300, который работает в linux /ubuntu 13.04, но только после некоторого ворчания. (Обновление декабря 2013 года: те же проблемы остаются в 13.10)

Мне нужно настроить режим предпочтительной полосы пропускания на «Воспроизведение высокой точности воспроизведения» (A2DP) каждый раз после включения компьютера и повторного подключения динамика.

Режим сбрасывается на «телефонию /дуплекс» (= низкая пропускная способность) каждый раз. Для перезагрузки динамика требуется около 20 щелчков, (щелкнуть меню, отключить, снова подключить, выбрать режим, тест), и это, безусловно, слишком много кликов.

Как я могу сделать режим «A2DP» режимом по умолчанию, а сделать это постоянным образом?

Несколько иллюстраций экрана иллюстрируют.

После выбора этого меню, щелкнув значок Bluetooth на верхней панели в Unity ...

Значок Bluetooth на панели

После настройки этого ...

A2DP

... предпочтительный режим будет сброшен до этого после перезапуска /приостановки компьютера

Дуплекс телефонии

38 голосов | спросил knb 14 J000000Sunday13 2013, 13:04:53

5 ответов


22

В /etc/bluetooth/audio.conf есть опция: AutoConnect=true, который хэшируется.

sudo nano /etc/bluetooth/audio.conf

Удалите «#» в начале строки AutoConnect = true

Мне удалось включить эту опцию, удалив # и получив правильное подключение к моей гарнитуре bluetooth

Перезапустите службу bluetooth, чтобы изменения вступили в силу:

sudo service bluetooth restart
ответил Joe 21 SunEurope/Moscow2014-12-21T16:12:14+03:00Europe/Moscow12bEurope/MoscowSun, 21 Dec 2014 16:12:14 +0300 2014, 16:12:14
21

Добавьте следующую строку в /etc/bluetooth/audio.conf:

[General]
Disable=Headset

, а затем выполните следующую команду:

sudo service bluetooth restart

Тема: (Natty) Подключить только профиль A2DP для гарнитуры bluetooth.

ответил amagnoni 11 FebruaryEurope/MoscowbTue, 11 Feb 2014 06:07:50 +0400000000amTue, 11 Feb 2014 06:07:50 +040014 2014, 06:07:50
4

Для тех, кого интересует, я нашел в Ubuntu 16.04, есть небольшая разница в ответе:

sudo gedit /etc/bluetooth/main.conf

И обновите следующую строку

#AutoEnable=false

к

AutoEnable=true

Далее

sudo service bluetooth restart

Для меня это по умолчанию означает, что аудиофайл подключен к A2DP Sink при подключении аудиоустройства Bluetooth.

ответил N.AbdullaSunderland 2 ndEurope/Moscowp30Europe/Moscow09bEurope/MoscowSat, 02 Sep 2017 14:01:10 +0300 2017, 14:01:10
3

Я использую Gnome3, и через некоторое время моя гарнитура больше не подключается к A2DP. Мне пришлось остановить Gnome, создав демона pulseaudio, создав файл /var/lib/gdm3/.config/pulse/client.conf (от имени root) и добавив к нему следующие строки:

autospawn = no
daemon-binary = /bin/true

Затем установите владельца в gdm:

sudo chown gdm:gdm /var/lib/gdm3/.config/pulse/client.conf

Затем откройте /запустите или найдите процесс pulseaudio, запущенный в качестве пользователя gdm с ps aux | grep pulse

Вывод

(Trimmed) выглядит следующим образом:

gdm       2943  10616 ?        S<l  Sep01   0:00 /usr/bin/pulseaudio..

Затем запустите процесс с помощью kill <pid>, который для меня был 2943

Запуск bluetoothctl и повторное подключение, я мог бы запустить pacmd list-cards и найдите мое устройство index: 2 и измените на a2dp_sink с помощью pacmd set-card-profile 2 a2dp_sink

Наконец, снова работаем!

ответил Dylan 30 AM00000080000002331 2017, 08:23:23
0

Для автоматического переключения звука на устройство Bluetooth A2DP при подключении в Ubuntu 14.04 я выполнил инструкции из https: //sandalov.org/blog/2146/, и он отлично работал.

Измените /etc/pulse/default.pa, чтобы автоматически переключать пульсовый приемник на Bluez:

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
load-module module-switch-on-connect  # Add this
.endif

Измените /etc/bluetooth/audio.conf для автоматического выбора профиля A2DP (вместо HSP /HFP):

[General]
Disable=Headset # Add this

Применить изменения:

pulseaudio -k # Restarts pulseaudio
sudo service bluetooth restart # Restarts BT

Дополнительная информация: https://wiki.archlinux.org/index. PHP /Bluetooth_headset

ответил Caumons 11 +03002017-10-11T11:35:22+03:00312017bEurope/MoscowWed, 11 Oct 2017 11:35:22 +0300 2017, 11:35:22

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132