Заглушка экрана в X-Windows на Raspbian

Я участвую в аналогичном проекте и выдаю его как OP с отключением экрана (выход HDMI), запустив Raspbian Server 2.4:

Стандартный пользователь pi регистрирует сеанс, который автоматически запускается после загрузки.

Я пробовал разные подходы без везения:

  

.xinitrc

exec unclutter -root -noevents &
while sleep 5
do
        $HOME/websnurra-ng/websnurra-ng http://test.se
done

xset s off
xset s noexpose
xset -dpms
xset s noblank
setterm -blank 0 -powersave off -powerdown 0
  

/и т.д. /X11 /Xinit /xinitrc

#!/bin/sh

# /etc/X11/xinit/xinitrc
#
# global xinitrc file, used by all X sessions started by xinit (startx)

# invoke global X session script
. /etc/X11/Xsession
xset s off
xset -dpms
xset s noblank
setterm -blank 0 -powersave off -powerdown 0
  

/etc/rc.local

setterm -blank 0 -cursor off

Я запустил команды xset вручную в терминале, и они выполняют правильный просмотр xset q так же, как и при загрузке файлов конфигурации, хотя через несколько минут экран по-прежнему отключается.

Я хотел выполнить их как root, чтобы узнать, не изменит ли это, но в итоге появится сообщение об ошибке:

X11 connection rejected because of wrong authentication.
xset:  unable to open display "localhost:10.0"

Права доступа:

  

pi @ raspberrypi ~ $ ls -la

totalt 112
drwxr-xr-x 8 pi   pi    4096 okt 18 11:39 .
drwxr-xr-x 3 root root  4096 maj 25 18:35 ..
-rw------- 1 pi   pi    4184 okt 18 11:31 .bash_history
-rw-r--r-- 1 pi   pi     220 maj 25 18:35 .bash_logout
-rw-r--r-- 1 pi   pi    3243 maj 25 18:35 .bashrc
drwxr-xr-x 3 pi   pi    4096 okt 15 14:53 .config
drwxr-xr-x 2 pi   pi    4096 jun 12 14:01 Desktop
drwxr-xr-x 2 pi   pi    4096 okt  8 15:03 .gstreamer-0.10
-rw-r--r-- 1 pi   pi    5781 feb  3  2013 ocr_pi.png
-rwxr-xr-x 1 pi   pi     175 jun 12 16:00 pkgs.sh
-rw-r--r-- 1 root root 36740 jun 12 15:23 pkgs.txt
-rw-r--r-- 1 pi   pi     675 maj 25 18:35 .profile
drwxrwxr-x 2 pi   pi    4096 mar 10  2013 python_games
drwx------ 2 pi   pi    4096 okt 15 14:32 .ssh
drwxr-xr-x 3 pi   pi    4096 okt 18 08:25 websnurra-ng
-rw------- 1 pi   pi      57 okt 18 11:39 .Xauthority
-rw-r--r-- 1 pi   pi     210 okt 18 11:25 .xinitrc
-rw-r--r-- 1 pi   pi     181 okt 17 09:40 .xinitrc.save
  

pi @ raspberrypi /etc /X11 /xinit $ ls -la

totalt 16
drwxr-xr-x 2 root root 4096 okt  8 14:03 .
drwxr-xr-x 9 root root 4096 okt  8 14:04 ..
-rw-r--r-- 1 root root  246 okt 18 11:25 xinitrc
-rwxr-xr-x 1 root root   56 okt 17 10:33 xserverrc
  

pi @ raspberrypi /etc $ ls -la rc.local

-rwxr-xr-x 1 pi pi 553 okt 18 13:40 rc.local
4 голоса | спросил nicoX 18 +04002013-10-18T13:57:10+04:00312013bEurope/MoscowFri, 18 Oct 2013 13:57:10 +0400 2013, 13:57:10

3 ответа


3

Я создал файл xorg.conf со следующим вводом и теперь он остается:

Section "Monitor"
    Identifier "Monitor"
    Option "DPMS" "false"
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "BlankTime"  "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection
ответил nicoX 18 +04002013-10-18T17:54:56+04:00312013bEurope/MoscowFri, 18 Oct 2013 17:54:56 +0400 2013, 17:54:56
1

Что я сделал, чтобы отключить гашение экрана на моей малине Pi 2 с помощью Raspbian.

Создал файл на /etc/X11/Xsession.d/:

# /etc/X11/Xsession.d/98x11-screen_blank
xset s off
xset -dpms
xset s noblank

Убедитесь, что у вас установлен xset. У последнего Raspbian уже есть это.

ответил Roberto Focosi 5 J000000Tuesday16 2016, 00:16:11
0

Просто хотел поместить это там, чтобы другие, которые искали эту проблему (гашение экрана), могли найти этот ответ полезным.

В /etc /xdg /lxsession есть два каталога (LXDE и LXDE-pi)

ПРИМЕЧАНИЕ. Это, если вы используете графический интерфейс (например: в моем случае загрузка на терминал с использованием startx)

Многие форумы говорят, чтобы отредактировать файл автозапуска в LXDE, но это не решило мою проблему. Что нужно сделать, чтобы отредактировать автозапуск в LXDE-pi с помощью ниже.

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
#@xscreensaver -no-splash

@xset s noblank
@xset s off
@xset -dpms

Затем выполните перезагрузку, если необходимо.
Используемая версия: Версия: Raspbian GNU /Linux 7 \ n \ l

Надеюсь, что кто-то найдет это полезным.

ответил smilks 3 FebruaryEurope/MoscowbTue, 03 Feb 2015 22:47:14 +0300000000pmTue, 03 Feb 2015 22:47:14 +030015 2015, 22:47:14

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132