Как заставить Raspberry Pi включить HDMI?

У меня есть малина Pi, работающая Raspbmc , подключенная через HDMI к немому HDTV. (Не поддерживает HDMI-CEC).

Если я одновременно включаю телевизор (как у источника, так и через пульт дистанционного управления) и Raspbmc, все работает нормально.

Если я подключаюсь к Raspbmc и телевизору, но телевизор не включается. Спустя некоторое время я использую пульт телевизора для включения телевизора, после чего я получаю пустой экран на телевизоре через HDMI. Это не заставка, потому что использование пульта XBMC ничего не меняет. Raspbmc активен, потому что я могу ping и подключиться к нему с помощью SSH .

Есть ли параметр в Raspbmc, который я могу изменить, чтобы он всегда включал HDMI , независимо от того, включен или выключен телевизор?

87 голосов | спросил Ashwin Nanjappa 11 +04002012-10-11T17:55:19+04:00312012bEurope/MoscowThu, 11 Oct 2012 17:55:19 +0400 2012, 17:55:19

2 ответа


94

Добавьте эти две строки в /boot/config.txt и перезагрузите Raspbmc:

hdmi_force_hotplug=1
hdmi_drive=2

hdmi_force_hotplug=1 устанавливает Raspbmc для использования режима HDMI, даже если монитор HDMI не обнаружен. hdmi_drive=2 устанавливает режим Raspbmc в обычный режим HDMI (звук будет отправлен, если поддерживается и включен). Без этой строки Raspbmc по умолчанию переключится на DVI (без звука).

ответил Dennis Williamson 11 +04002012-10-11T18:20:07+04:00312012bEurope/MoscowThu, 11 Oct 2012 18:20:07 +0400 2012, 18:20:07
1

Хотя этот вопрос очень старый, я хотел бы опубликовать свой ответ, который я нашел недавно. Я бегу Raspberry PI 2 Model B с 2,8 PiTFT capactive дисплеем. Как только я понял, как заставить мой дисплей в режиме реального времени работать с малиновым PI, я не мог заставить малиновый PI переключиться на выход HDMI независимо от того, что я сделал. Затем я наткнулся на эту информацию, которая работала для меня.

Есть два способа сделать это. В старых установках Pi используйте фреймбуфер fb0, когда вы хотите отображать информацию на экране HDMI /TV, например: FRAMEBUFFER = /dev /fb0 startx будет использовать фреймбуфер HDMI /TV для X-окон вместо PiTFT

На Jessie Pi устанавливается, запускается sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf для редактирования файла конфигурации и убедитесь, что он содержит: Копировать код

Section "Device"
  Identifier "display"
  Driver "fbdev"
  Option "fbdev" "/dev/fb0"
EndSection

измените опцию «fbdev» «/dev /fb0» на параметр «fbdev» «/dev /fb1», если вы хотите, чтобы xdisplay на PiTFT или fb1 был fb0 для выхода HDMI.

Обновление: Если вы не видите код выше в файле, просто скопируйте и вставьте то, что показано в этом ответе внизу этого файла. Если вы не можете найти файл 99-fbdev.conf в этой папке, возможно, есть еще один файл с другим именем, например 10-evdev.conf , в той же папке, вам придется изменить, чтобы он работал, как описано выше.

ответил ThN 25 J000000Monday16 2016, 17:40:17

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132