Загрузка без запуска X-сервера

Во время установки Raspian я выбрал «Запустить X-Server после загрузки», но теперь я хочу загрузить его один раз без запуска X-Server, поэтому у меня больше памяти для запуска программы.

Как мне загрузиться без запуска X-Server?

81 голос | спросил Stein 28 J000000Saturday12 2012, 03:26:00

3 ответа


86

С изображением Raspbian вы можете повторно запустить начальный скрипт запуска, используя:

$ sudo raspi-config

и введите пароль sudo.

Это вызовет те же параметры меню, которые вы получили после первой загрузки.

Вам не нужно переделывать все свои первые варианты загрузки, просто используйте клавиши со стрелками, чтобы перейти к параметрам меню, которые вы хотите изменить.

В вашем случае выберите:

  

Запустить X-сервер после загрузки?

и выбрав:

  

нет или отключить

будет сортировать вас.

Редактирование для добавления опций, не связанных с gui:

Как отмечено в комментариях ниже @mirk, точная команда для малины:

sudo update-rc.d lightdm disable
ответил zenbike 28 J000000Saturday12 2012, 07:26:36
22

Как работает X.Org, у вас есть менеджер рабочего стола, который загружает X-сервер для вас. Это означает, что для предотвращения запуска X-сервера вам нужно удалить менеджер destkop из списка демонов.

Если вы используете GNOME, вы являетесь настольным менеджером GDM. Если вы используете KDE, вы являетесь настольным менеджером, который будет KDM. Для этого я собираюсь предположить, что вы используете GNOME; ergo вы используете GDM в качестве менеджера вашего рабочего стола.

В Raspian диспетчер рабочего стола называется LightDM.

Чтобы отключить демон в Debian (для которого Raspbian является fork), вы должны выполнить следующую команду.

$ sudo update-rc.d <daemon> disable

Итак, чтобы отключить LightDM, мы должны запустить следующую команду.

$ sudo update-rc.d lightdm disable

И теперь при следующей перезагрузке LightDM не должен запускаться и, в свою очередь, не запускать X Server.

Ссылки

  1. Отключение демонов - Daemon - Debian Wiki
ответил 28 J000000Saturday12 2012, 04:33:15
8

Принятый ответ не работал для меня в версии «Jessie», я закончил использование:

sudo systemctl set-default multi-user.target

Ссылка: Попытка отключить X11 в Джесси

ответил crobicha 19 PMpWed, 19 Apr 2017 20:03:05 +030003Wednesday 2017, 20:03:05

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132