Конфигурация WiFi в Arch Linux ARM

Я купил модель A Pi, и я успешно настроил ее с помощью USB Wifi-ключа на Raspbian. Недавно я подготовил SD-карту с последней версией Arch Linux ARM, и я пытаюсь настроить ее с помощью WiFi. Я пытался следовать Raspbian WiFi-учебнику (думая, что он может быть таким же, как Arch Linux ARM), который сказал, что есть каталог /etc/network/, и вы можете настроить Wi-Fi из интерфейс, но не существует каталога interface. Я слышал о /etc/network/, но у меня нет идеи, как его использовать! I do имеет поддерживаемый USB-ключ Wi-Fi. Может кто-нибудь, пожалуйста, покажите мне, как я могу настроить WiFi на Arch Linux ARM? Спасибо!

22 голоса | спросил user151324 15 J0000006Europe/Moscow 2013, 18:17:38

2 ответа


26

Устаревший netcfg используется /etc/network.d/ для хранения профилей. Преемником netcfg является netctl .

Чтобы настроить беспроводную сеть, установите netctl, используя sudo pacman -S netctl. Затем вам нужно создать сетевой профиль. /etc/netctl/examples/ содержит некоторые примеры. Предположим, вы хотите настроить сеть WPA2-PSK. Просто скопируйте файл примера и начните редактирование:

/etc/netctl# install -m640 examples/wireless-wpa wireless-home
/etc/netctl# cat wireless-home
Description='A simple WPA encrypted wireless connection'
Interface=wlan0
Connection=wireless
Security=wpa

IP=dhcp

ESSID='MyNetwork'
# Prepend hexadecimal keys with \"
# If your key starts with ", write it as '""<key>"'
# See also: the section on special quoting rules in netctl.profile(5)
Key='WirelessKey'
# Uncomment this if your ssid is hidden
#Hidden=yes

Изменить MyNetwork и WirelessKey по мере необходимости. Обратите внимание на разрешения 640, вы не хотите просачивать беспроводную кодовую фразу в мир!

Продолжить тестирование:

# netctl start wireless-home

Если вы не получили сообщение об ошибке, вы должны быть подключены. Давайте проверим это:

$ ping 8.8.8.8

Чтобы запустить эту сеть при загрузке:

# netctl enable wireless-home
ответил Lekensteyn 16 J0000006Europe/Moscow 2013, 13:50:28
4

Сначала это не сработало. Следуя приведенным выше инструкциям, мне пришлось запустить

systemctl включить netctl-auto @ wlan0

, чтобы он работал. Я нашел ответ на форуме ArchLInux Arm

ответил user12295 23 Jam1000000amThu, 23 Jan 2014 08:25:48 +040014 2014, 08:25:48

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132