android — Подпись GoogleSignatureVerifier не верна (Google Play Services 9.0.0)" />

Подпись GoogleSignatureVerifier не верна (Google Play Services 9.0.0)

Недавно я обновил библиотеку сервисов Google Play до версии 9.0.0 и получаю следующее сообщение logcat:

05-19 23:07:30.023 19237-19508/? V/GoogleSignatureVerifier: options.developer.com.developeroptions signature not valid.  Found: 

Хотя мое приложение не использует API карт Google, но использует аналитику, рекламу и API Google Plus.

Единственное упоминание в документации, касающееся использования ключа api, - это использование карт Google или приложений api для Android.

Я также попытался добавить 'com.google.android.geo.API_KEY' с правильным ключом, но это не помогло.

вот мой файл gradle.build:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.3"

    defaultConfig {
        applicationId "options.developer.com.developeroptions"
        minSdkVersion 9
        targetSdkVersion 23
        versionCode 23
        versionName "1.06"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}


dependencies {
    compile 'com.google.android.gms:play-services-plus:9.0.0'
    compile 'com.android.support:appcompat-v7:23.2.0'
    compile 'com.google.android.gms:play-services-analytics:9.0.0'
    compile 'com.google.android.gms:play-services-ads:9.0.0'
}
100 голосов | спросил meh 19 Maypm16 2016, 23:17:44

5 ответов


0

Извините, это ошибка! Хотя это просто ложная регистрация: сервисы Google Play проверяют, являетесь ли вы приложением Google или обычным сторонним приложением.

Как часть этого, он вызывает верификатор подписи, и запись в журнал стала более многословной, чем предполагалось - это будет исправлено в будущей версии. Это не должно повлиять на поведение вашего приложения вообще.

ответил Ian Barber 23 Mayam16 2016, 00:20:46
0

В сети вы найдете множество решений, но единственное, что работает для меня, - это понизить версию Google Play Services до 8.7.02 на моих устройствах. Я надеюсь, что Google быстро исправит эту ошибку: ')

ответил Filoux 24 Mayam16 2016, 10:43:30
0

Как уже упоминалось в других ответах, на Google Play Services 9 происходит обновление до устройства. Вы можете иметь эти параметры, пока Google не исправит ошибку:

  • Безопасно игнорируйте его

  • Понижение версии телефона /устройства с помощью «Настройки» -> «Приложения» -> «Службы Google Play» (три точки в верхнем правом меню) -> Удалить

    Если кнопки «Отключить /Принудительно остановить» неактивны, вам может потребоваться удалить приложение из списка «Администратор устройства» перед его удалением.

Блог Google plus, касающийся ошибки: https://plus.google.com/+ ChristopheBeyls /сообщений /LC2XCSoaVBJ

Удаление /воссоздание файла keystore.debug вряд ли поможет. Если вы уже сделали это, вам нужно будет создать новый, используя «консоль разработчика map api»

ответил JMax 6 J0000006Europe/Moscow 2016, 17:51:44
0
  1. убедитесь, что вы правильно ввели синатуру SHA и имя пакета.

  2. убедитесь, что вы включили свой API GoogleMaps в вашем ApiManager> Обзор после создания проекта в консоли API (найдите его в Google)

  3. убедитесь, что вы разрешили доступ к Интернету в файле манифеста

  4. в вашем файле сборки используйте compile 'com.google.android.gms: play-services: 9.0.1' (работает для меня)

В моем случае я пропустил шаг 3.

ответил Shubham Arora 12 J0000006Europe/Moscow 2016, 00:28:55
0

Мне пришлось обновить библиотеку gms до 9.0.1 и удалить все сохраненные данные из сервисов Google Play на моем телефоне, и журналы больше не отображались. Они вызывали у меня «И» в моем приложении раньше, что вызывало у меня сильные головные боли, почему это происходило.

ответил box 3 J0000006Europe/Moscow 2016, 17:38:33

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132