android-studio — Ошибка при запуске Android: Сбой синхронизации проекта Gradle. Пожалуйста, исправьте ваш проект и попробуйте снова" />

Ошибка при запуске Android: Сбой синхронизации проекта Gradle. Пожалуйста, исправьте ваш проект и попробуйте снова

Android Studio (1.2 RC0) постоянно говорит мне Error running android: Gradle project sync failed. Please fix your project and try again. Как я могу узнать, в чем проблема? К сожалению, решения из этой темы SO сделали не поможет.

69 голосов | спросил SePröbläm 22 PMpWed, 22 Apr 2015 23:31:19 +030031Wednesday 2015, 23:31:19

21 ответ


0
  1. Перейти к файлу -> Недействительные кэши /перезапуск
  2. Завершение работы Android Studio
  3. Переименовать /удалить папку .gradle в домашнем каталоге пользователя
  4. Перезапустите Android Studio (загрузятся метаданные и данные).
  5. Сборка Gradle выполнена успешно
  6. Перестроить проект. Готово.
ответил toha 13 AM00000050000000031 2016, 05:38:00
0

Решение

  1. Подключите компьютер к Интернету

  2. Нажмите

  

Sync project with Gradle files

На панели инструментов введите описание изображения здесь

Он автоматически синхронизирует Gradle.

ответил tsigehiwet kahsayu 8 Jpm1000000pmMon, 08 Jan 2018 14:15:47 +030018 2018, 14:15:47
0

Просто проигнорируйте ошибку и попробуйте запустить проект в любом случае. Это не удастся, но на этот раз вы получите ссылку в описании ошибки. Нажатие на ссылку приведет к автоматическому обновлению /загрузке устаревшего /отсутствующего компонента.

В моем случае проект не запустился два раза, каждый раз виновником был другой компонент API /SDK.

В моем случае я просто пытался запустить загруженный образец проекта, не зная, какой уровень API был задан или где искать эту информацию.

ответил brett 16 42017vEurope/Moscow11bEurope/MoscowThu, 16 Nov 2017 06:24:38 +0300 2017, 06:24:38
0
  1. Загрузите, например, последний пакет Gradle дистрибутив ( gradle-2.11-all.zip ).
  2. Извлеките этот zip-файл в папку, как, например, ( D: //Gradle )
  3. Загрузите свой проект в Android Studio и перейдите в Файл-> Настройки-> Gradle. Нажмите Использовать локальное распространение Gradle и укажите его в папке, в которую вы распаковали последний проект Gradle.
  4. Перезапустите свой проект
ответил Ali 22 FebruaryEurope/MoscowbMon, 22 Feb 2016 10:14:59 +0300000000amMon, 22 Feb 2016 10:14:59 +030016 2016, 10:14:59
0

Перейти на

file->settings->build,execution,deployment->gradle.

(и укажите домашний путь Gradle из вашего каталога)

ответил KAT 6 WedEurope/Moscow2017-12-06T14:59:49+03:00Europe/Moscow12bEurope/MoscowWed, 06 Dec 2017 14:59:49 +0300 2017, 14:59:49
0

У меня вчера была та же проблема. После открытия «Android SDK Manager», обновления всех пакетов и перезапуска Android Studio, проект снова скомпилирован.

ответил Cristian-Leonard Miehs 24 PMpFri, 24 Apr 2015 14:51:29 +030051Friday 2015, 14:51:29
0

Это очень распространенная проблема, и решение очень простое ... Просто обновите SDK в менеджере SDK (см. Подробные инструкции ниже)

  1. Откройте Android Studio и перейдите в свой менеджер SDK (Файл> Настройки> SDK Менеджер)
  2. Проверьте значок (-) перед любой упаковкой и нажмите на нее.
  3. Нажмите кнопку ОК, чтобы начать обновление SDK.

Спасибо, что задали этот вопрос:)

ответил HT Land 9 42017vEurope/Moscow11bEurope/MoscowThu, 09 Nov 2017 09:12:23 +0300 2017, 09:12:23
0

Если сообщения об ошибках не отображаются: иногда они отображаются в командной строке. Просто перейдите в командную строку, перейдите в каталог app и введите

gradle installDebug

или, если детали отсутствуют

gradle --info installDebug

Это может предоставить дополнительную информацию о том, как отладить проблему.

ответил serv-inc 4 FebruaryEurope/MoscowbSun, 04 Feb 2018 15:53:50 +0300000000pmSun, 04 Feb 2018 15:53:50 +030018 2018, 15:53:50
0

Перейти к файлу -> Недействительные кэши /перезапуск Отключение Android Studio Переименуйте /удалите папку .gradle в домашнем каталоге пользователя. Перезапустите Android Studio (загрузятся метаданные и данные). Успешная сборка Перестроить проект. Готово

ответил randikawann 16 MarpmFri, 16 Mar 2018 20:21:52 +03002018-03-16T20:21:52+03:0008 2018, 20:21:52
0

это выглядит по-разному в разных ситуациях. для меня я сделал установку и обновил много вещей, которые сказал менеджер SDK, тогда у меня была эта проблема. все, что я сделал, было: из файла -> Недействительные кэши /перезапуск (появится диалоговое окно), выберите «Invalidate» и перезапустите.

после перезагрузки. все было исправлено, но мне нужно было создать новый эмулятор и удалить старый. (андроид студия 1.3.1) (один специалист должен отредактировать это, чтобы быть более понятным) , , , Здесь все было хорошо, но ваши машины также нуждаются в перезагрузке, потому что некоторые системные файлы изменены, для их синхронизации нам нужно перезагрузить систему.

ответил Ayham Rustom 3 MarpmFri, 03 Mar 2017 20:59:46 +03002017-03-03T20:59:46+03:0008 2017, 20:59:46
0

Мне потребовалось некоторое время, чтобы решить эту проблему.

  • Обновлен инструмент сборки SDK [не помогло]
  • Обновлен CMake [не помогло]
  • Обновлены инструменты платформы Android SDK [не помогло]
  • Обновлены инструменты Android SDK [Не помогло]
  • Обновлен NDK [Проблема решена]

Была причина, я не хотел обновлять NDK. Когда все остальное не удалось, я обновил NDK, и это помогло.

ответил Asma Zubair 29 FriEurope/Moscow2017-12-29T00:13:10+03:00Europe/Moscow12bEurope/MoscowFri, 29 Dec 2017 00:13:10 +0300 2017, 00:13:10
0

Если у вас истекло время ожидания, проверьте Gradle Scripts -> gradle.properties в Android Studio, я обнаружил, что установил socket прокси в настройках Android Studio, но в этом файле gradle.properties мой прокси стал http, поэтому я просто удалил этот http proxy setting строки и, наконец, работает.

ответил fangxing 15 J000000Sunday18 2018, 05:07:58
0

У меня возникла эта проблема на Android-студии, там была либо ссылка, либо синяя рамка, была эта ссылка, как синий текст об этой проблеме, нажмите эту кнопку и загрузите что-нибудь, что решит эту проблему

ответил 3Dblog 23 PM00000010000002831 2018, 13:31:28
0

Разрешение простое. Откройте «Android SDK Manager», обновите все пакеты и перезапустите Android Studio. После этого ваш проект должен быть скомпилирован без проблем.

ответил mac.slusarek 7 Mayam17 2017, 00:24:06
0

Возможно, вы используете gradle в автономном режиме. Чтобы снять флажок, перейдите в File > Settings > Gradle, снимите флажок с Offline Work установите флажок и нажмите Apply Убедитесь, что у вас есть подключение к Интернету, и снова синхронизируйте проект.

ответил Kwabena Berko 2 J000000Monday18 2018, 15:09:51
0

Очевидно, некоторые платформы могут отсутствовать. Вот как я решил проблему:

Вы видите сообщение об ошибке, которое отображается внизу окна Android Studio? Это может быть также маленькое окно в правом нижнем углу .., которое выглядит так:

 введите описание изображения здесь

Теперь нажмите на эту синюю ссылку, сделайте так, как говорят диалоговые окна (если есть) ...

Это решило проблему. Надеюсь, это поможет ...

ответил ThePerson 5 +03002018-10-05T09:18:26+03:00312018bEurope/MoscowFri, 05 Oct 2018 09:18:26 +0300 2018, 09:18:26
0

Я столкнулся с той же проблемой, но затем сделал следующее, и моя проблема была решена:

  • обновленный Gradle
  • установил последнюю версию Android студии (моя устарела)

И это решило мою проблему.

Примечание. Это также помогло мне щелкнуть журнал событий, поскольку он содержит более подробную информацию об ошибках. https://developer.android.com/studio/releases/gradle- Плагин # update-plugin также имеет отличную информацию.

ответил chthonicThreat 26 +03002018-10-26T05:34:21+03:00312018bEurope/MoscowFri, 26 Oct 2018 05:34:21 +0300 2018, 05:34:21
0

Загрузите файлы оценок по этому URL и извлеките все в папке: https://gradle.org/releases

Открыть файл -> Настройка в ОС Windows или Настройки в Mac OS и в «Сборка, Выполнение, Развертывание»

Нажмите "Gradle"

Установите флажок «Использовать локальное распространение из базовой станции» и укажите путь к этой извлеченной папке.

Запустите gradle.bat для ОС Windows и файл gradle для Mac OS в этой папке.

Затем отметьте «Автономная работа».

«путь к вашей извлеченной папке» /gradle-4.10.2/bin/.gradle (для версии 4.1.2 вы можете указать свою версию)

Нажмите ОК и наслаждайтесь.

ответил Yilmazam 19 12018vEurope/Moscow11bEurope/MoscowMon, 19 Nov 2018 23:26:53 +0300 2018, 23:26:53
0

Удалить папку «build» из корневой папки проекта. Затем выполните «аннулировать кэш и перезапустите». Это перезапустит вашу Android Studio, а затем снова соберет приложение, решит проблему.

ответил Ashish Agrawal 4 Jam1000000amFri, 04 Jan 2019 09:49:58 +030019 2019, 09:49:58
0

это было трудно решить, но я сделал это смотри, иди C: \ Users (имя пользователя)

удалить файл .gradle его вы не видели он может быть в скрытых файлах , так что если вы используете Windows 7  щелкните правой кнопкой мыши, затем выберите свойства и нажмите скрытые, чтобы их не отмечали

тогда появится файл и удалите его я надеюсь, что это работает

ответил Zeyad Asem 7 MarpmTue, 07 Mar 2017 17:58:21 +03002017-03-07T17:58:21+03:0005 2017, 17:58:21
0

Это потому, что gradle не синхронизирован по многим причинам.

Перейдите в папку проекта, удалите папку .gradle и запустите синхронизацию. Это будет работать

ответил yubaraj poudel 14 AM00000080000003931 2018, 08:49:39

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132