android-studio — Android Studio не запускается, говорит, что компоненты не установлены" />

Android Studio не запускается, говорит, что компоненты не установлены

Я установил последнюю версию Android-студии от Google. После запуска он пытается загрузить некоторые пакеты.

Через некоторое время появляется следующая ошибка.

  

Следующие компоненты SDK не были установлены: extra-android-m2repository, tools, addon-google_apis-google-21, android-21, sys-img-x86-addon-google_apis-google-21, source-21, extra -google-m2repository

Мне не удалось исправить ошибку, хотя я несколько раз нажимал Retry .

Любой может предложить решение!

66 голосов | спросил Jeeva 9 TueEurope/Moscow2014-12-09T13:17:44+03:00Europe/Moscow12bEurope/MoscowTue, 09 Dec 2014 13:17:44 +0300 2014, 13:17:44

27 ответов


0

Я столкнулся с подобной проблемой в Windows 7 и получил указанные ниже проблемы при первом запуске ярлыка android-studio из меню «Пуск».

Screenshot_1

  

Решение: Запуск от имени администратора

Проблема возникла из-за разрешения записи в Windows C: и Access is Denied сообщение отображается. Запуск программы от имени администратора загружает все необходимые компоненты, и теперь я могу запустить Android Studio IDE.

Android Studio - Мастер установки успешно работает как администратор

Update:

Эти проблемы с разрешениями отсутствуют в последних версиях Android Studio (проверено в 1.3.2 в Windows 10) и работают без команд «Запуск от имени администратора». Если у вас все еще есть проблема со старыми /последними версиями, то это могут быть проблемы с брандмауэром и прокси. В этом случае проверьте другие ответы.

ответил Lucky 18 ThuEurope/Moscow2014-12-18T08:25:25+03:00Europe/Moscow12bEurope/MoscowThu, 18 Dec 2014 08:25:25 +0300 2014, 08:25:25
0

Windows: запуск от имени администратора, Linux: sudo

ответил Michał Sułek 10 WedEurope/Moscow2014-12-10T01:42:25+03:00Europe/Moscow12bEurope/MoscowWed, 10 Dec 2014 01:42:25 +0300 2014, 01:42:25
0

Возможное решение - проверить настройки прокси-сервера; под Windows 7 вы можете найти эти настройки в файле other.xml, который находится по пути C:\Users\YourUsername\\.AndroidStudio\config\options.

Обратите внимание, что если вы установите оба параметра «USE_HTTP_PROXY» и «USE_PROXY_PAC» в значение true, ошибка будет появляться, но должно появиться всплывающее окно с замечанием проблемы двойной конфигурации и предложением разрешения с окном ввода для этих параметров.

ОБНОВЛЕНИЕ - возможное решение

Мне только что удалось завершить работу мастера дома, возможно, прокси-сервер не является настоящей проблемой (как указывалось в последнем комментарии @meanderingmoose). Кажется, есть проблема с установщиком по умолчанию для Android Studio 1.0.0, который содержит как IDE, так и di SDK Tools: путь установки по умолчанию для инструментов Android SDK заканчивается на myInstallPath../sdk/android-sdk, но параметр первого запуска для Android Studio указывает на ..myInstallPath../sdk. Итак, вот что я сделал.

  • Cut & Вставьте содержимое папки android-sdk вне папки, чтобы файлы находились в ..myInstallPath../sdk/
  • Используйте SDK Manager из нового местоположения для обновления всего (используйте это вместо автоматического мастера, вы можете выбрать, какой пакет вам нужен или нужен, а также вы получите скорость и примерное время загрузки)
  • Запустите Android Studio (он должен загрузить и убедиться, что SDK обновлен, и начать создание AVD, после чего IDE загрузится полностью)

ОБНОВЛЕНИЕ - Обходной путь для проблемы "загрузка прервана: время ожидания чтения истекло"

Брандмауэр и прокси-сервер не позволили моему SDK Manager загрузить некоторые обновления, поэтому я восстановил URL-адрес .xml для этих обновлений, искал нужные мне файлы .zip и напрямую загрузил их с помощью диспетчера загрузки, Затем я вручную установил их в их относительную папку в папке SDK .. немного сложно, но работал для меня. Например, в Addon_xml_file я искал m2repository, нашел запись и скачал архив по ссылке m2repository_r14_zip_file . Вы всегда найдете нужные файлы в той же базе, что и файл .xml (посмотрите на URL, который я разместил для примера).

ответил nbarzan 9 TueEurope/Moscow2014-12-09T19:06:23+03:00Europe/Moscow12bEurope/MoscowTue, 09 Dec 2014 19:06:23 +0300 2014, 19:06:23
0

В OS X запустите от имени администратора в первый раз, открыв новый терминал и выполнив команды:

cd /Applications/Android\ Studio.app/Contents/MacOS/

sudo ./studio

ответил Wronski 27 SatEurope/Moscow2014-12-27T13:49:11+03:00Europe/Moscow12bEurope/MoscowSat, 27 Dec 2014 13:49:11 +0300 2014, 13:49:11
0

Android Studio не удалось подключиться к Интернету на моем рабочем компьютере из-за настроек прокси /брандмауэра в интрасети, изменение настроек прокси мне тоже не помогло.

Не удалось запустить Android-студию, так как она требует установки вышеупомянутых пакетов. В качестве обходного пути я установил пакеты из Android SDK Manager , и он решил это.

Менеджер SDK находится в разделе C: \ Users \ <ИмяПользователь > \ AppData \ Local \ Android \ sdk \ SDK Manager.exe В графическом интерфейсе выберите следующие параметры в зависимости от того, что имеет отношение.

  • Инструменты-> Все инструменты сборки Android SDK и инструменты платформы SDK версии 21. *
  • Все под Android 5.0.1 (API 21)
  • Все в разделе "Дополнительно"

После завершения установки попробуйте запустить Android Studio

ответил Carbine 28 Jam1000000amWed, 28 Jan 2015 10:22:51 +030015 2015, 10:22:51
0

В OSX я решил эту проблему следующим образом:

Шаг 1:

Перейдите в Системные настройки> Сеть: продвинутая

введите описание изображения здесь обойти dl-ssl.google.com

Шаг 2:

Перейдите в прокси и установите обходные прокси следующим образом:

введите описание изображения здесь

ответил Gaurav Gupta 31 WedEurope/Moscow2014-12-31T21:39:26+03:00Europe/Moscow12bEurope/MoscowWed, 31 Dec 2014 21:39:26 +0300 2014, 21:39:26
0

Пожалуйста, не запускайте Настольные приложения от имени пользователя root. Это опасная привычка.

Мне удалось решить эту проблему, закрыв окно с (X) в правом верхнем углу. Он спросил меня, нужно ли запускать мастер установки в следующий раз, чего вы не хотите. Тогда андроид студия запустилась нормально. После этого запустите android SDK manager и нажмите «Установить» в правом нижнем углу.

Надеюсь, это поможет

ответил Chris K. 22 PMpWed, 22 Apr 2015 15:48:05 +030048Wednesday 2015, 15:48:05
0

Вместо стандартной установки для Android Studio я использую выборочную установку, и она работает для меня !!.

введите описание изображения здесь

ответил Sahir Saiyed 30 PMpThu, 30 Apr 2015 14:05:02 +030005Thursday 2015, 14:05:02
0

В Windows я смог заставить его работать, выполнив следующие действия:

1) Загрузите build-tools-21.1.1 по следующей ссылке: http://dl-ssl.google.com/android/repository/build-tools_r21.1.1-windows.zip

2) В Windows SDK для Android будет расположен в: C: \ Users \ \ AppData \ Android \ sdk (по умолчанию папка AppData будет скрыта, вы можете сделать ее видимой в «Параметры папки»)

3) По этому пути - C: \ Users \ \ AppData \ Android \ sdk \ build-tools, вы уже найдете папку "21.1.2". По тому же пути создайте новую папку и назовите ее «21.1.1»

4) Разархивируйте пакет, который вы скачали на шаге 1. Скопируйте содержимое папки «android-5.0» и вставьте ее в папку «21.1.1», созданную на шаге 3).

5) Запустите Android Studio

ответил akashrajkn 14 Jam1000000amWed, 14 Jan 2015 10:54:14 +030015 2015, 10:54:14
0

Нажмите Show Details во время загрузки компонентов, и вы получите больше информации о том, что на самом деле происходит.

В моем случае это была проблема с разрешением. Чтобы решить, я просто выполнил скрипт с помощью sudo. (sudo ./studio.sh (что решит проблемы с разрешениями в случае сред Linux). Если вы работаете в Windows, запустите метод установки от имени администратора. (Если это командный файл, используйте командную строку администратора, если это исполняемый файл, запустите от имени администратора и т. Д.)

ответил Alexander Kohler 10 WedEurope/Moscow2014-12-10T01:16:58+03:00Europe/Moscow12bEurope/MoscowWed, 10 Dec 2014 01:16:58 +0300 2014, 01:16:58
0

В Windows решена с помощью этого файла, который позволил мне обновить SDK через графический интерфейс: C: \ Users \% UserName% \ AppData \ Local \ Android \ sdk \ tools \ android.bat

Android начал работать нормально после обновления SDK.

Примечание. Запуск C: \ Users \% UserName% \ AppData \ Local \ Android \ sdk \ SDK Manager.exe в моей системе ничего не сделал.

ответил rayzinnz 13 Mayam15 2015, 05:10:05
0

Этот ответ предназначен для OSX

Мне нужно было решить две вещи, чтобы успешно установить Android Studio:

  1. Убедитесь, что вы не используете прокси-сервер, который мешает вам получить доступ к ресурсам Android. Если вы используете корпоративный прокси-сервер, убедитесь, что вы настроили параметры в Android Studio> Настройки > Фильтр для Прокси-сервера . Если вы не видите Лицензионное соглашение (Согласен /Не согласен), значит ваше соединение не достигает серверов загрузки Google
  2. Запустите rm -rf ~ /.android . Это было важно, чтобы это работало на меня. Предыдущая установка или что-то еще повлияло на кэши загрузки. Лучше всего взломать его и начать все заново.
ответил applejack42 14 Jam1000000amWed, 14 Jan 2015 10:28:09 +030015 2015, 10:28:09
0

Я нахожусь в Индии, и моя связь не работала должным образом. (У меня есть интернет, но иногда у меня есть пустая страница на Chrome, и мне нужно обновить)

Я несколько раз пытался перезапустить андроид студию (почти 15 раз). И теперь это работает.

Возможно, у вас такая же проблема.

ответил Johnny Johnson 10 WedEurope/Moscow2014-12-10T00:56:36+03:00Europe/Moscow12bEurope/MoscowWed, 10 Dec 2014 00:56:36 +0300 2014, 00:56:36
0
  1. отключить антивирус
  2. работать от имени администратора
  3. выйдите из системы и начните снова
ответил vuhung3990 11 ThuEurope/Moscow2014-12-11T07:46:11+03:00Europe/Moscow12bEurope/MoscowThu, 11 Dec 2014 07:46:11 +0300 2014, 07:46:11
0

Для меня эта проблема была связана с прокси. В Mac OSX , даже если отображается вышеуказанная ошибка, вверху есть строка меню для Android Studio . Выберите настройки Android Studio -> Preferences и измените прокси, как показано ниже, и проблема была решена. В Windows /Linux могут быть похожие параметры для доступа к странице настроек во время отображения ошибки.

введите описание изображения здесь

ответил Kiran 17 WedEurope/Moscow2014-12-17T08:01:32+03:00Europe/Moscow12bEurope/MoscowWed, 17 Dec 2014 08:01:32 +0300 2014, 08:01:32
0

Если вы используете Linux, я заметил, что Android Studio не может быть запущен с JDK 8. Вы должны скачать open Jdk 7 и нажать alt + shift + t и введите:

sudo apt-get install openjdk-7-jre 

Когда вы загрузите jdk 7, перейдите в терминал, перейдите в android-studio /bin и введите

sudo sh ./studio.sh 
ответил Basil Battikhi 21 SunEurope/Moscow2014-12-21T12:42:32+03:00Europe/Moscow12bEurope/MoscowSun, 21 Dec 2014 12:42:32 +0300 2014, 12:42:32
0

Я столкнулся с той же проблемой, пытаясь настроить Android Studio с работы. Запуск от имени администратора не решил мою проблему, и у меня нет прямого доступа к настройкам прокси /брандмауэра. В конце концов я решил проблему с помощью Android SDK Manager и установив соответствующие пакеты. Некоторые из имен пакетов и сообщений об ошибках (из-за сбоя установки студии) не совпадали напрямую, но быстрый поиск в Google показал мне свет.

Надеюсь, это поможет!

ответил IdusOrtus 13 Jpm1000000pmTue, 13 Jan 2015 21:38:45 +030015 2015, 21:38:45
0

Наконец-то я смог решить эту проблему.

Не устанавливайте Android SDK со студийным пакетом, снимите флажок, когда появится запрос.

Шаги для решения:

  • Загрузите последнюю версию Android SDK, поэтому при запуске runnning studio она не загружает никаких дополнительных пакетов. Распакуйте в /yourAndroidSDKPath
  • Снимите флажок Android SDK при установке студии.
  • При появлении запроса укажите /yourAndroidSDKPath в студийной установке. Это работает для меня.

Я пробовал другие решения, запустил с правами администратора и прокси, но ничего не получалось.

ответил Anoop 25 Jam1000000amSun, 25 Jan 2015 11:30:37 +030015 2015, 11:30:37
0

Обновите последние инструменты Android SDK из диспетчера SDK и удалите прокси-сервер, который я ввел для подключения Android-студии к vpn.

ответил Eftekhari 7 MarpmSat, 07 Mar 2015 16:38:08 +03002015-03-07T16:38:08+03:0004 2015, 16:38:08
0

У меня есть прокси в моем соединении (соединение с университетом), и я решил проблему с помощью диспетчера SDK для загрузки пакетов SDK, затем я открыл android studio, и он работал без проблем.

ответил Med Zamrik 24 WedEurope/Moscow2014-12-24T11:25:43+03:00Europe/Moscow12bEurope/MoscowWed, 24 Dec 2014 11:25:43 +0300 2014, 11:25:43
0

У меня также были проблемы с OS X Yosemite при новой установке Android Studio.

Моя ситуация заключалась в том, что я использовал VPN. В настройках я настроил настройку прокси-сервера HTTP на автоматическое обнаружение после попытки запустить его как sudo и настройки статического прокси-сервера, но ни одна из них не сработала. После этого я смог успешно загрузить. Надеюсь, что это поможет кому-то в аналогичной ситуации (VPN).

Настройки HTTP-прокси Android

ответил Grant 4 Jam1000000amSun, 04 Jan 2015 07:20:06 +030015 2015, 07:20:06
0

В OSX (Yosemite) у меня возникла та же проблема. Попробовав несколько других ответов, я изменил файлы каталога установки, чтобы они принадлежали мне:

  

cd /Applications /android-sdk-mac_x86

     

chown -R *

Где моя учетная запись?

Проблема, с которой я столкнулся при выполнении установки root, заключается в том, что некоторые файлы оказались в домашнем каталоге корневой учетной записи, а другие - в моем, когда я начал использовать Android Studio.

ответил EPage_Ed 4 FebruaryEurope/MoscowbWed, 04 Feb 2015 03:26:53 +0300000000amWed, 04 Feb 2015 03:26:53 +030015 2015, 03:26:53
0

Я использовал нестандартную установку вместо стандартной, и это решило проблему! (просто выберите пользовательский, и вы сможете установить все как стандарт)

ответил kakhkAtion 2 J0000006Europe/Moscow 2015, 19:44:07
0

Одно из возможных решений - открыть Android SDK Manager из

C:\Users\%user%\AppData\Local\Android\sdk

Загрузите и установите средство сборки Android SDK 21.1.1. Перезапустите Android Studio

ответил Muhammad Aamir Ali 2 FebruaryEurope/MoscowbMon, 02 Feb 2015 15:14:49 +0300000000pmMon, 02 Feb 2015 15:14:49 +030015 2015, 15:14:49
0

Для OSX (Mac)

Я пытался установить в качестве администратора (sudo), но это не сработало


После этого я решаю проблему этим,

при настройке выберите пользовательскую настройку вместо стандартной настройки

тогда, это решит эту проблему

ответил Sruit A.Suk 6 J000000Monday15 2015, 21:47:16
0

Немного поздно, но у меня тоже была эта проблема, и запуск студии, поскольку root только создавал больше проблем (используя OSX здесь).

Я исправил это, вручную установив то, что не удалось установить, используя менеджер Android SDK. Просто запустите android sdk в терминале (вероятно, то же самое в Windows, но не цитируйте меня). Пусть он установит все необходимые обновления, а затем, если вы не можете сделать это через установку, вручную найдите пакеты, которые не удалось установить, и установите их.

Получил меня через очень неприятную проблему и вернулся к работе .....

ответил jamzsabb 25 Maypm15 2015, 19:41:24
0

"Следующее Компоненты SDK не были установлены: sys-img-x86-addon-google_apis-google-22 и addon-google_apis-google-22 ".

Я бы предложил закрыть окно вместо нажатия кнопки "Готово" и не запускать мастер установки.

ответил Dhruv 27 J0000006Europe/Moscow 2015, 17:33:08

Похожие вопросы

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132