npm-install — все вопросы

2ответа
4 голоса
Как получить количество установленных модулей npm, кроме зависимостей dev
Есть ли команда CLM NPM, которую я могу использовать для получения количества модулей NPM, установленных в моем пакете, кроме тех, которые являются только зависимостями Dev? npm ls показывает все пак
3ответа
4 голоса
Как мне обращаться с каталогом `node_modules` при облачном хранилище?
У меня есть проект Node.js (на самом деле это Firebase проекта), где у меня есть код в Google Drive. (Я мог бы использовать, например, Dropbox здесь. Важно то, что файлы кода являются зеркальными.)
1ответ
4 голоса
Пересоздание узла не удалось в Mac OS High Sierra во время установки npm
Я получаю следующую ошибку в терминале, когда он пытается установить один из пакетов "node-expat". Я попытался переключиться на другую версию узла с помощью nvm, но все равно происходит сбой с той ж
1ответ
4 голоса
Ошибка после установки Ag Grid - Angular 2
после следующих инструкций " https://www.ag-grid.com/best-angular-2-data-grid/?framework=angular#gsc.tab=0 " установить ag-grid для угловых 2 и запустить команды Npm я ag-grid - сохранить npm я ag-g
2ответа
4 голоса
«печатание» не распознается как внутренняя или внешняя команда, работающая программа или командный файл
Резюме Я пытаюсь установить набор текста для моего веб-приложения, но не могу получить командную строку для распознавания команды typings . Проблема typings install выдает следующую ошибку:
4ответа
4 голоса
Почему мне нужно запускать npm install каждый раз, когда я создаю новый проект angular 2?
Каждый раз, когда я делаю новый угловой проект, он говорит "node_modules выглядит пустым, вам может потребоваться запустить` npm install "
2ответа
4 голоса
[email protected] требует однорангового узла response @ ^ 15, но ни один не установлен Вы должны установить одноранговые зависимости самостоятельно
Я установил все необходимые библиотеки, используя npm install, и я также сделал npm install --save [email protected] но я все еще получаю эту ошибку. Мой Package.json "author": "", "li
3ответа
4 голоса
Модуль NPM находится в папке /node_modules, но не может быть найден?
У меня возникла небольшая проблема с установкой модуля узла md5 на сервер Ubuntu dev, который я настроил. (Он отлично работает на моей локальной машине с Windows, и я могу отлично установить друг
1ответ
4 голоса
Установка NPM не запускает сборку Babel, если зависимости не приходят из NPM
Например, если в моем package.json у меня есть это: "dependencies": { "cacheman": "2.1.0" } он работает и запускает сценарий сборки внутри cacheman, когда я делаю npm install. Однако
5ответов
4 голоса
EINTEGRITY: проверка целостности npm 5.0 и зависимость от modernizr.com
Я столкнулся с этой ошибкой при установке deps моего пакета:проблема в моей ---- +: = 1 =: + ---- зависимости:Есть ли способ решить эту проблему или игнорировать эту проверку целостности?В настоящее в
4ответа
4 голоса
ошибка: пакет com.cboy.rn.splashscreen не существует
я использовал этот пакет пакета native-native, и он работал нормально, пока я не удалил все и не начал заново, после того, как настроил свой проект.я сделал "а потом ---- +: = 1 =: + ---- и он мне пок
4ответа
4 голоса
ошибка: пакет com.cboy.rn.splashscreen не существует
я использовал этот пакет пакета native-native, и он работал нормально, пока я не удалил все и не начал заново, после того, как настроил свой проект.я сделал "а потом ---- +: = 1 =: + ---- и он мне пок
2ответа
4 голоса
ng build - сбой сборки prod после запуска npm install в новой папке
Вот ошибка, возникающая при сборке prodОшибка: новые версии пакетов устанавливаются после запуска npm install.Невозможно поделиться разницей версий пакетов, поскольку список слишком длинныйОн работает
3ответа
4 голоса
Ошибка при попытке установить response-devtools
Я пытаюсь установить response-devtools с этим кодомпосле выполнения этой команды я получаю эту ошибку.Как я могу это исправить?Я отчаянно нуждаюсь в devtools для отладки.Если возможно, предложите лучш
1ответ
4 голоса
когда npm i imagemin говорит, что сам не устанавливается?
npm -v 6.4.1 nvm - версия 0.33.11когда я устанавливаю laravel-echo (в Ubuntu16.04)Я получил предупреждение об ошибкеПоэтому я продолжаю устанавливать ихНо я получил сам пропущенную ошибку?Я тоже стара
1ответ
4 голоса
Не удалось установить Docker npm
Я пытаюсь создать веб-приложение ASP.Net 5.0 с помощью Docker, но оно не удается, когда он достигает этапа установки npm, с помощью:Я не вижу здесь никаких ошибок, объясняющих причину сбоя, только ПРЕ
4ответа
4 голоса
Ошибка установки Npm EPERM Операция не разрешена
Поэтому при попытке запустить проект angular4 сегодня моей первой ошибкой было: ---- +: = 0 =: + ----, поэтому я подумал удалить папку модулей узла и повторить попытку.Но, запустив npm install, я стал
3ответа
4 голоса
Получение ошибки: не удается найти модуль «./src/init» при попытке инициализировать реагирующее собственное приложение
Когда я пытаюсь установить реагировать родной с помощью команды ---- +: = 0 =: + ----Я получаю следующее:Почему это происходит?Раньше он работал, единственное, что я помню, я изменил, это некоторые па
8ответов
4 голоса
Установка NPM зависает на loadRequestedDeps
Когда я загружаю любой пакет с помощью NPM, он зависает от последней команды «loadRequestedDeps».Я добавил весь свой вывод ---- +: = 0 =: + ---- в конец этого вопроса для справки.Он будет просто сидет
4ответа
4 голоса
Не имеет экспортированных членов «MdCardModule» и «MdTooltipModule»
Когда я запускаю ---- +: = 0 =: + ---- Он показывает некоторые ошибки:ОШИБКА в C: /761 /панель поиска /workload_management_app /Client /src /app /app.module.ts (8,9): Модуль '"C: /761 /панель поиска /
1 2

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132