pip — все вопросы

1ответ
4 голоса
Обновление сообщения об ошибке Pip
Когда я бегу pip install --upgrade pip Я получаю это сообщение об ошибке: Collecting pip Downloading pip-8.1.0-py2.py3-none-any.whl (1.2MB) 100% |█████████████████████████████
2ответа
4 голоса
Распространение скрипта Python, который зависит от пакета
Я написал скрипт, который использует Selenium, я установил Selenium через pip. Есть ли способ, которым я могу распространять этот скрипт среди других, не устанавливая Selenium через pip? Я смотре
2ответа
4 голоса
установка pip с использованием прокси в виртуальной среде
Я работаю на Ubuntu VM на ноутбуке моей компании, который использует прокси-сервер для подключения к Интернету. После некоторых исследований я узнал, как устанавливать модули, используя pip install
2ответа
4 голоса
Лучший способ распространять большие и сложные проекты Python, чтобы они полностью устанавливались для других пользователей, независимо от операционной системы?
Как обеспечить, чтобы распространение пакетов Python с большими зависимостями, таких как NumPy и SciPy, автоматически правильно устанавливалось на компьютерах пользователей, независимо от их ОС?
1ответ
4 голоса
Как сравнить файл требований и фактически установленные модули Python?
Учитывая requirements.txt и среду virtualenv, каков наилучший способ проверить из сценария , являются ли требования встречаются и, возможно, предоставить подробности в случае несоответствия? Pip
3ответа
4 голоса
Как импортировать пакеты Python?
Я новичок в Python и мне нужно использовать инструмент на основе python, называемый хромосомер, который импортирует некоторые пакеты python, включая биоформаты. Биоформаты имеют много модулей, включ
3ответа
4 голоса
Python 3.6, установка pip, matplotlib и другие библиотеки завершились неудачно в Windows 10
Недавно у меня появился новый ноутбук, и я хочу установить все свои библиотеки Python. Однако некоторые из них просто не устанавливаются, например, matplotlib. О моем компьютере: Windows 10 с Pyt
2ответа
4 голоса
Скрипт установки пакета Python устанавливает двоичный исполняемый файл
У меня есть пакет awesomepkg с setup.py. Я хотел бы установить исполняемый файл awesometool в командную строку вместе с самим пакетом, когда пользователи запускают pip install awesomepkg. Я скомпили
1ответ
4 голоса
«git clone…» работает, но не «pip install ...» для того же удаленного URL
Я хочу установить пакет через pipenv или pip + virtualenv из частного удаленного хранилища с доступом по ssh. Пока работает клонирование: git clone [email protected]:username/package.git прямой уст
2ответа
4 голоса
Как автоматически обновить pywin32?
Как я понимаю, использовать pip для установки /обновления нельзя pywin32, хотя pip install -U pypiwin32 это обходной путь. pywin32 теперь размещен на GitHub . Я очень мало знаю о git, но знаю, ч
1ответ
4 голоса
Команда python3 не найдена после установки python с помощью pyenv
Я установил определенную версию python с помощью pyenv. При вводе pyenv version в терминале, я вижу 3.5.0 (set by /Users/lcherukuri/.python-version). Но когда я набрал python3, я получил python3 comm
1ответ
4 голоса
Когда я делюсь своим проектом на Python, который использует pip, как я могу убедиться, что у пользователя установлены программы pip?
У меня есть проект на python, который использует инструменты /программы из командной строки с именем pip. Как я могу убедиться, что у пользователя есть все инструменты, которые я использую на своем
1ответ
4 голоса
Как я могу получить pip для перечисления репозиториев, которые он использует?
Я пытаюсь запустить кодовую базу на моем компьютере, а pip не находит некоторые зависимости. Кажется, что они находятся на другом компьютере, поэтому я хотел бы посмотреть, какой пипс используется н
1ответ
4 голоса
Установка Anisible pip3 продолжает происходить с ошибкой на удаленном сервисе (на удаленном хосте не найдены установочные инструменты, сначала установите его)
Я пытаюсь настроить свои удаленные серверы и заставить Anisble установить необходимые пакеты. В моем playbook.yml все работает нормально, кроме случаев, когда он пытается установить requirments.txt
1ответ
4 голоса
`pip` не удалось установить пакет внутри контейнера Docker из-за ошибки 'Move Permanently', возвращенной из https: //pypi.python.org /simple /`
Я хотел бы установить пакеты pip внутри Ubuntu 14.04 docker, но всегда отображаются ошибки из-за Move Permanently возвращается из https://pypi.python.org/simple/. Странный (?) Момент в том, что на х
4ответа
4 голоса
Есть ли более простой способ упаковки с Python?
Сегодня я попытался упаковать приложение django. Это большой ребенок, и с помощью установочного файла я должен вручную написать все пакеты и подпакеты в параметре package. Затем я должен найти спосо
1ответ
4 голоса
Разверните субпакет с distutils и pip
Я хочу создать набор взаимосвязанных пакетов в Python. Я хотел бы, чтобы все они были в одном пакете, но устанавливались как отдельные компоненты. Так, например, установка базового пакета предост
2ответа
4 голоса
Заморозка требований к пипсам, NumPy и SciPy на OS X
У меня есть файл требований pip, который я использую с virtualenv для автоматического получения зависимостей для моего приложения. Приложение зависит как от NumPy, так и от SciPy, и поэтому мой ф
1ответ
4 голоса
Установка пакета Pip с предустановленными зависимостями
Я хотел бы установить некоторые пакеты Python из локальных каталогов (загруженных с GitHub), указанных в requirements.txt -e ./src/django-django-eca4737 -e ./src/divio-django-appmedia-55835b6 -e .
1ответ
4 голоса
pip не устанавливает мои data_files. Но easy_install делает
Это будет короткий вопрос. Источник здесь: https://github.com/exhuma/grc И название объясняет мою проблему;) Я зарегистрировал и загрузил пакет в pypi. Теперь, если я запускаю easy_instal
1 2 3 4 5 6

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132