requirements.txt — все вопросы

2ответа
4 голоса
Замена зависимости пользовательскими вилками с помощью pip
Я создаю приложение, которое использует photologue и несколько других пакетов с photologue как зависимость (например, cmsplugin-photologue). Однако мне нужно использовать модифицированную версию pho
1ответ
4 голоса
Как сравнить файл требований и фактически установленные модули Python?
Учитывая requirements.txt и среду virtualenv, каков наилучший способ проверить из сценария , являются ли требования встречаются и, возможно, предоставить подробности в случае несоответствия? Pip
1ответ
4 голоса
ImportError: Нет модуля с именем base в html5lib
Я внезапно не могу запустить сервер Django, запустив проверку:показывает к следующей ошибке:У тебя есть идеи?
1ответ
4 голоса
Что является эквивалентом twiddle-wakka (~>) из гема ruby ​​в файле require.txt для пипа python?
Я видел оператор twiddle-wakka (~>), используемый в гем-файле ruby ​​( документация ) для указания последней версии, совместимой с точкой:Я вижу, что в ---- +: = 2 =: + ---- есть оператор ---- +: =
2ответа
10 голосов
Невозможно установить с помощью pip install needs.txt [закрыто]
Я пытаюсь установить BitTornado для Python 2.7, используя require.txt Я получаю следующую ошибку: Collecting requirements.txt Could not find a version that satisfies the requirement requiremen
4ответа
44 голоса
Проверьте, актуальны ли требования
Я использую pip файлы требований для хранения моего списка зависимостей. Я также стараюсь следовать рекомендациям по управлению зависимостями и предоставлять точные версии пакетов в файле требо

Популярные теги

security × 330linux × 316macos × 2827 × 268performance × 244command-line × 241sql-server × 235joomla-3.x × 222java × 189c++ × 186windows × 180cisco × 168bash × 158c# × 142gmail × 139arduino-uno × 139javascript × 134ssh × 133seo × 132mysql × 132